aboutsummaryrefslogtreecommitdiffstats
path: root/randpkt_core/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /randpkt_core/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'randpkt_core/Makefile.am')
-rw-r--r--randpkt_core/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/randpkt_core/Makefile.am b/randpkt_core/Makefile.am
index 5f8456784d..d46b9be4b4 100644
--- a/randpkt_core/Makefile.am
+++ b/randpkt_core/Makefile.am
@@ -19,7 +19,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
@@ -37,8 +36,8 @@ MAINTAINERCLEANFILES = \
# All sources that should be put in the source distribution tarball
librandpkt_core_a_SOURCES = \
- $(RANDPKT_CORE_SRC) \
- $(noinst_HEADERS)
+ randpkt_core.c \
+ randpkt_core.h
librandpkt_core_a_DEPENDENCIES =
@@ -57,15 +56,14 @@ checkapi: checkapi-base checkapi-todo
checkapi-base:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
-sourcedir=$(srcdir) \
- $(RANDPKT_CORE_SRC)
+ $(librandpkt_core_a_SOURCES)
checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
- $(RANDPKT_CORE_SRC)
+ $(librandpkt_core_a_SOURCES)
EXTRA_DIST = \
$(GENERATOR_FILES) \
CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common
+ doxygen.cfg.in