aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimax/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-05-26 18:26:46 +0000
committerGuy Harris <guy@alum.mit.edu>2007-05-26 18:26:46 +0000
commit62955d62fe70b3f1b8d8bf2d330fbc42893ca1ff (patch)
treebd0fbb8f5e0a4a11515a640e1e4ca736ed403133 /plugins/wimax/Makefile.am
parent292543bc1cf207377fd130e972c3107d9235c330 (diff)
Convert to the new style of building plugins; hopefully this'll fix the
rest of the distcheck issues. svn path=/trunk/; revision=21953
Diffstat (limited to 'plugins/wimax/Makefile.am')
-rw-r--r--plugins/wimax/Makefile.am99
1 files changed, 84 insertions, 15 deletions
diff --git a/plugins/wimax/Makefile.am b/plugins/wimax/Makefile.am
index 3bf4f0dc93..179122df4f 100644
--- a/plugins/wimax/Makefile.am
+++ b/plugins/wimax/Makefile.am
@@ -1,10 +1,10 @@
# Makefile.am
-# Automake file for Wireshark WiMax Plugin
+# Automake file for Wireshark WiMAX Plugin
#
# $Id$
#
# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# By Gerald Combs <gerald@wireshark.org>
# Copyright 1998 Gerald Combs
#
# This program is free software; you can redistribute it and/or
@@ -22,21 +22,23 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
-INCLUDES = -I$(top_srcdir)
+INCLUDES = -I$(top_srcdir) -I$(includedir)
+
+include Makefile.common
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
plugindir = @plugindir@
plugin_LTLIBRARIES = wimax.la
-wimax_la_SOURCES = packet-wmx.c wimax_ffb_decoder.c wimax_fch_decoder.c wimax_pdu_decoder.c\
- wimax_cdma_code_decoder.c wimax_hack_decoder.c wimax_phy_attributes_decoder.c \
- mac_hd_generic_decoder.c mac_hd_type1_decoder.c mac_hd_type2_decoder.c \
- mac_mgmt_msg_decoder.c msg_dcd.c msg_ucd.c msg_dlmap.c msg_ulmap.c \
- msg_rng_req.c msg_rng_rsp.c msg_reg_req.c msg_reg_rsp.c msg_dreg.c \
- msg_dsa.c msg_dsc.c msg_dsd.c msg_arq.c msg_sbc.c msg_pkm.c msg_aas_fbck.c \
- msg_fpc.c msg_pmc.c msg_prc_lt_ctrl.c msg_aas_beam.c msg_res_cmd.c msg_rep.c \
- msg_clk_cmp.c msg_dsx_rvd.c wimax_harq_map_decoder.c \
- wimax_compact_dlmap_ie_decoder.c wimax_compact_ulmap_ie_decoder.c \
- wimax_utils.c crc.c crc_data.c wimax_tlv.c moduleinfo.h
+wimax_la_SOURCES = \
+ plugin.c \
+ moduleinfo.h \
+ $(DISSECTOR_SRC) \
+ $(DISSECTOR_SUPPORT_SRC) \
+ $(DISSECTOR_INCLUDES)
wimax_la_LDFLAGS = -module -avoid-version
wimax_la_LIBADD = @PLUGIN_LIBS@
@@ -45,12 +47,79 @@ wimax_la_LIBADD = @PLUGIN_LIBS@
# add them here.
LIBS =
+#
+# Build plugin.c, which contains the plugin version[] string, a
+# function plugin_register() that calls the register routines for all
+# protocols, and a function plugin_reg_handoff() that calls the handoff
+# registration routines for all protocols.
+#
+# We do this by scanning sources. If that turns out to be too slow,
+# maybe we could just require every .o file to have an register routine
+# of a given name (packet-aarp.o -> proto_register_aarp, etc.).
+#
+# Formatting conventions: The name of the proto_register_* routines an
+# proto_reg_handoff_* routines must start in column zero, or must be
+# preceded only by "void " starting in column zero, and must not be
+# inside #if.
+#
+# DISSECTOR_SRC is assumed to have all the files that need to be scanned.
+#
+# For some unknown reason, having a big "for" loop in the Makefile
+# to scan all the files doesn't work with some "make"s; they seem to
+# pass only the first few names in the list to the shell, for some
+# reason.
+#
+# Therefore, we have a script to generate the plugin.c file.
+# The shell script runs slowly, as multiple greps and seds are run
+# for each input file; this is especially slow on Windows. Therefore,
+# if Python is present (as indicated by PYTHON being defined), we run
+# a faster Python script to do that work instead.
+#
+# The first argument is the directory in which the source files live.
+# The second argument is "plugin", to indicate that we should build
+# a plugin.c file for a plugin.
+# All subsequent arguments are the files to scan.
+#
+plugin.c: $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
+ $(top_srcdir)/tools/make-dissector-reg.py
+ @if test -n $(PYTHON); then \
+ echo Making plugin.c with python ; \
+ $(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
+ plugin $(DISSECTOR_SRC) ; \
+ else \
+ echo Making plugin.c with shell script ; \
+ $(top_srcdir)/tools/make-dissector-reg $(srcdir) \
+ $(plugin_src) plugin $(DISSECTOR_SRC) ; \
+ fi
+
+#
+# Currently plugin.c can be included in the distribution because
+# we always build all protocol dissectors. We used to have to check
+# whether or not to build the snmp dissector. If we again need to
+# variably build something, making plugin.c non-portable, uncomment
+# the dist-hook line below.
+#
+# Oh, yuk. We don't want to include "plugin.c" in the distribution, as
+# its contents depend on the configuration, and therefore we want it
+# to be built when the first "make" is done; however, Automake insists
+# on putting *all* source into the distribution.
+#
+# We work around this by having a "dist-hook" rule that deletes
+# "plugin.c", so that "dist" won't pick it up.
+#
+#dist-hook:
+# @rm -f $(distdir)/plugin.c
+
CLEANFILES = \
wimax \
*~
MAINTAINERCLEANFILES = \
- Makefile.in
+ Makefile.in \
+ plugin.c
EXTRA_DIST = \
- Makefile.nmake
+ Makefile.common \
+ Makefile.nmake \
+ moduleinfo.nmake \
+ plugin.rc.in