aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimax/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-04-07 21:41:34 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-04-17 16:09:22 +0000
commite280df605f10a548e8f19e290c33dc4080b715c0 (patch)
tree5f626dc2930c27d0988e70c68835b1d1da15b9a8 /plugins/wimax/CMakeLists.txt
parent1948d026f6e89e3346ce1b0a45a6a2bf24e577d9 (diff)
Fix CMake warnings
Newer versions of CMake generate warnings about the use of @variable@ references, replace @CPACK_PACKAGE_NAME@ with ${CPACK_PACKAGE_NAME} Set the policy for CMP0026 to be old to squelch warnings about the use of target LOCATION Change-Id: I424083260c51875dde80f98a23d6528c31ff0aec Reviewed-on: https://code.wireshark.org/review/7977 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Jörg Mayer <jmayer@loplof.de> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'plugins/wimax/CMakeLists.txt')
-rw-r--r--plugins/wimax/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/wimax/CMakeLists.txt b/plugins/wimax/CMakeLists.txt
index 5ae094465d..73d46e88ae 100644
--- a/plugins/wimax/CMakeLists.txt
+++ b/plugins/wimax/CMakeLists.txt
@@ -101,7 +101,7 @@ register_dissector_files(plugin.c
add_plugin_library(wimax)
install(TARGETS wimax
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
- RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
)