aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimax/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-03-18 10:27:17 +0000
committerJörg Mayer <jmayer@loplof.de>2010-03-18 10:27:17 +0000
commit96779de920fa5f308f29c35dce54d48e5d19b670 (patch)
tree447b5cb2f49d91c4f87cd170ac0fe6f6b032117a /plugins/wimax/CMakeLists.txt
parent1e0bcd0740f5c3f71a6e194d0f09deef0489d53d (diff)
cmake changes:
- Add checking for linker flags - Install plugins with the name including the Wireshark version. This will make it easier to find matching plugin versions if files get just copied over. svn path=/trunk/; revision=32231
Diffstat (limited to 'plugins/wimax/CMakeLists.txt')
-rw-r--r--plugins/wimax/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/wimax/CMakeLists.txt b/plugins/wimax/CMakeLists.txt
index a2fd7d9007..c3bb5c151a 100644
--- a/plugins/wimax/CMakeLists.txt
+++ b/plugins/wimax/CMakeLists.txt
@@ -98,12 +98,13 @@ add_library(wimax ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(wimax PROPERTIES PREFIX "")
-#set_target_properties(wimax PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(wimax PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(wimax PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(wimax epan)
install(TARGETS wimax
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)