aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-07-30 20:22:37 +0000
committerGuy Harris <guy@alum.mit.edu>2007-07-30 20:22:37 +0000
commit968d363f113c73885a4c6c67019b0b8a93bf2524 (patch)
tree9cbfb86dfe1b0a83c37e8528dc019ef3885e0733 /plugins/mate/Makefile.am
parent0d437580eed2149e0d313aa00a64c11a4df37633 (diff)
Add comments to various %option items to explain what they're doing.
Move the %options to the beginning if they weren't already there, and put them in the same order in all files. Add "prefix=" options to .l files that don't already have them, so we don't have to pass a "-P" option. Add "never-interactive" and "noyywrap" options to our lexical analyzers, to remove extra isatty() checks and to eliminate the need for yywrap() from the Flex library. Get rid of %option nostdinit - that's the default. Add .l.c: rules to Makefile.am files, replacing the rules for specific .l files. Have those rules all check that $(LEX) is set. Update the address for the FSF. svn path=/trunk/; revision=22424
Diffstat (limited to 'plugins/mate/Makefile.am')
-rw-r--r--plugins/mate/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/plugins/mate/Makefile.am b/plugins/mate/Makefile.am
index ac5037b5dd..fb8f258bb8 100644
--- a/plugins/mate/Makefile.am
+++ b/plugins/mate/Makefile.am
@@ -130,8 +130,12 @@ EXTRA_DIST = \
moduleinfo.nmake \
plugin.rc.in
-mate_parser.c : mate_parser.l
- $(LEX) -Pdf_ -omate_parser.c $(srcdir)/mate_parser.l
+.l.c:
+ @if [ ! -x "$(LEX)" ]; then \
+ echo "Neither lex nor flex was found"; \
+ exit 1; \
+ fi
+ $(LEX) -o$@ $<
LEMON = ../../tools/lemon