aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
committerJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
commit9ee31d1d0e9a10ddb326bc7b23c22dc99bac7f6c (patch)
tree7e19b692aaacf4e9017a30429e79626a73f71a10 /plugins/mate/CMakeLists.txt
parentf6dfb9f323f6253c8c0470b8824d8846f5c578ab (diff)
cmake will now honor -Werror if configured (default: on)
svn path=/trunk/; revision=30852
Diffstat (limited to 'plugins/mate/CMakeLists.txt')
-rw-r--r--plugins/mate/CMakeLists.txt28
1 files changed, 21 insertions, 7 deletions
diff --git a/plugins/mate/CMakeLists.txt b/plugins/mate/CMakeLists.txt
index 88d6fad103..e15fed641b 100644
--- a/plugins/mate/CMakeLists.txt
+++ b/plugins/mate/CMakeLists.txt
@@ -33,12 +33,12 @@ set(DISSECTOR_SUPPORT_SRC
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-#mate_grammar.c : mate_grammar.lemon mate.h mate_util.h $(LEMON)/lemon$(EXEEXT)
-# $(LEMON)/lemon$(EXEEXT) t=$(srcdir)/$(LEMON)/lempar.c $(srcdir)/mate_grammar.lemon || \
-# (rm -f grammar.c grammar.h ; false)
+set(DISSECTOR_SUPPORT_CLEAN_SRC
+ ${DISSECTOR_SUPPORT_SRC}
+)
add_lemon_files(DISSECTOR_SUPPORT_SRC
- mate_grammar.lemon
+ mate_grammar.lemon
)
add_lex_files(DISSECTOR_SUPPORT_SRC
@@ -51,6 +51,20 @@ set(PLUGIN_FILES
${DISSECTOR_SUPPORT_SRC}
)
+set(CLEAN_FILES
+ plugin.c
+ ${DISSECTOR_SRC}
+ ${DISSECTOR_SUPPORT_CLEAN_SRC}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
register_dissector_files(plugin.c
plugin
${DISSECTOR_SRC}
@@ -67,8 +81,8 @@ add_library(mate MODULE
target_link_libraries(mate epan)
install(TARGETS mate
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
- RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)