aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2018-01-15 12:40:55 +0000
committerJoão Valverde <j@v6e.pt>2018-01-16 08:51:37 +0000
commit5352ef42f94b5c14a24eb2e5559440c71fdcae8f (patch)
tree22901b1d228d76360b22af10021564bcee36390e /plugins/mate/CMakeLists.txt
parenta069a4f856c29b25bae05f2a91d7b2b71e1905f3 (diff)
plugins: Add source tree subfolder for plugin library
This allows some simplification and makes things more consistent, particularly for loading plugins from the build dir. Also fixes the issue reported here: https://www.wireshark.org/lists/wireshark-dev/201801/msg00061.html Change-Id: I0d8a000ee679172bccad546a3b0c47a79486f44d Reviewed-on: https://code.wireshark.org/review/25329 Petri-Dish: João Valverde <j@v6e.pt> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'plugins/mate/CMakeLists.txt')
-rw-r--r--plugins/mate/CMakeLists.txt105
1 files changed, 0 insertions, 105 deletions
diff --git a/plugins/mate/CMakeLists.txt b/plugins/mate/CMakeLists.txt
deleted file mode 100644
index da7451b3e3..0000000000
--- a/plugins/mate/CMakeLists.txt
+++ /dev/null
@@ -1,105 +0,0 @@
-# CMakeLists.txt
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-
-include(WiresharkPlugin)
-
-# Plugin name and version info (major minor micro extra)
-set_module_info(mate 1 0 1 0)
-
-set(DISSECTOR_SRC
- packet-mate.c
-)
-
-set(DISSECTOR_SUPPORT_SRC
- mate_setup.c
- mate_runtime.c
- mate_util.c
-)
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-
-set(DISSECTOR_SUPPORT_CLEAN_SRC
- ${DISSECTOR_SUPPORT_SRC}
-)
-
-add_lemon_files(LEMON_FILES GENERATED_FILES
- mate_grammar.lemon
-)
-add_lex_files(LEX_FILES GENERATED_FILES
- mate_parser.l
-)
-
-set(PLUGIN_FILES
- plugin.c
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
- ${GENERATED_FILES}
-)
-
-set(CLEAN_FILES
- plugin.c
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_CLEAN_SRC}
-)
-
-set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
-)
-
-register_plugin_files(plugin.c
- plugin
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
-)
-
-add_plugin_library(mate epan)
-
-install_plugin(mate epan)
-
-file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")
-CHECKAPI(
- NAME
- mate
- SWITCHES
- -g abort -g termoutput -build
- SOURCES
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
- ${DISSECTOR_HEADERS}
-# LEX files commented out due to use of malloc, free etc.
-# ${LEX_FILES}
- ${LEMON_FILES}
-)
-
-#
-# Editor modelines - http://www.wireshark.org/tools/modelines.html
-#
-# Local variables:
-# c-basic-offset: 8
-# tab-width: 8
-# indent-tabs-mode: t
-# End:
-#
-# vi: set shiftwidth=8 tabstop=8 noexpandtab:
-# :indentSize=8:tabSize=8:noTabs=false:
-#