aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-01-10 21:29:57 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2015-01-11 20:22:32 +0000
commit528a8572582116a93e660ca93cdee36809b13b96 (patch)
tree250159b9a9000773d870b10bfa65726d9ed04e13 /plugins/mate/CMakeLists.txt
parent7d004dc887bcecb404241604242004edb6f6ceaa (diff)
Fix CMake generation and use of Windows .rc files
CMake now generates local copies of .rc files for all the Windows components and uses the files in the build of the components. The .rc.in files that include an icon were modified to allow the icon path to be set by CMake. The path is removed for nmake builds. Updated build architecture detection, required for wireshark.manifest.in Change-Id: I7b1ff43050e9b0efb861d1041636fb4aef49a4f8 Reviewed-on: https://code.wireshark.org/review/6482 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'plugins/mate/CMakeLists.txt')
-rw-r--r--plugins/mate/CMakeLists.txt26
1 files changed, 25 insertions, 1 deletions
diff --git a/plugins/mate/CMakeLists.txt b/plugins/mate/CMakeLists.txt
index e4dc6fe3b9..6372e54d1b 100644
--- a/plugins/mate/CMakeLists.txt
+++ b/plugins/mate/CMakeLists.txt
@@ -19,6 +19,30 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+# Create the Windows .rc file for the plugin.
+# The values come from several files in the source, I can't see how to reuse them
+
+# This info is from moduleinfo.nmake
+set(PACKAGE mate)
+set(MODULE_VERSION_MAJOR 1)
+set(MODULE_VERSION_MINOR 0)
+set(MODULE_VERSION_MICRO 0)
+set(MODULE_VERSION_EXTRA 1)
+set(MODULE_VERSION "${MODULE_VERSION_MAJOR}.${MODULE_VERSION_MINOR}.${MODULE_VERSION_MICRO}.${MODULE_VERSION_EXTRA}")
+set(RC_MODULE_VERSION "${MODULE_VERSION_MAJOR},${MODULE_VERSION_MINOR},${MODULE_VERSION_MICRO},${MODULE_VERSION_EXTRA}")
+
+# This info is from Makefile.common
+set(PLUGIN_NAME ${PACKAGE})
+
+# This info is from config.nmake
+set(MSVC_VARIANT "${CMAKE_GENERATOR}")
+
+# The rc.in requires a plain VERSION variable
+set(VERSION ${PROJECT_VERSION})
+
+# Create the plugin.rc file from the template
+configure_file(plugin.rc.in plugin.rc @ONLY)
+
set(DISSECTOR_SRC
packet-mate.c
)
@@ -70,7 +94,7 @@ register_dissector_files(plugin.c
add_library(mate ${LINK_MODE_MODULE}
${PLUGIN_FILES}
- plugin.rc
+ ${CMAKE_CURRENT_BINARY_DIR}/plugin.rc
)
set_target_properties(mate PROPERTIES