aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/m2m/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2015-01-18 13:27:13 -0800
committerGerald Combs <gerald@wireshark.org>2015-01-20 16:12:20 +0000
commit6e6a1291d0b36fe97d0f684e1abdfe546aaeae7f (patch)
treee441c514c057d4cadd74ae21ec6cc321b63ef285 /plugins/m2m/CMakeLists.txt
parentaf3924a333aa8fc614ad45163751a614a9b9fc3d (diff)
CMake: Set an output directory for plugins.
Redefine PLUGIN_DIR similar to DATAFILE_DIR and use it on all platforms. Add WiresharkPlugin.cmake so that we can start defining common macros for plugins/*/CMakeLists.txt. Load plugins in out-of-tree builds. Change-Id: I8c1359ed3cf8a71788b8320ff89dfe2d3969def2 Reviewed-on: https://code.wireshark.org/review/6640 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'plugins/m2m/CMakeLists.txt')
-rw-r--r--plugins/m2m/CMakeLists.txt43
1 files changed, 3 insertions, 40 deletions
diff --git a/plugins/m2m/CMakeLists.txt b/plugins/m2m/CMakeLists.txt
index 5cb5c9923f..5df4d3c284 100644
--- a/plugins/m2m/CMakeLists.txt
+++ b/plugins/m2m/CMakeLists.txt
@@ -19,29 +19,10 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-# Create the Windows .rc file for the plugin.
-# The values come from several files in the source, I can't see how to reuse them
+include(WiresharkPlugin)
# This info is from moduleinfo.nmake
-set(PACKAGE m2m)
-set(MODULE_VERSION_MAJOR 1)
-set(MODULE_VERSION_MINOR 1)
-set(MODULE_VERSION_MICRO 0)
-set(MODULE_VERSION_EXTRA 0)
-set(MODULE_VERSION "${MODULE_VERSION_MAJOR}.${MODULE_VERSION_MINOR}.${MODULE_VERSION_MICRO}.${MODULE_VERSION_EXTRA}")
-set(RC_MODULE_VERSION "${MODULE_VERSION_MAJOR},${MODULE_VERSION_MINOR},${MODULE_VERSION_MICRO},${MODULE_VERSION_EXTRA}")
-
-# This info is from Makefile.common
-set(PLUGIN_NAME ${PACKAGE})
-
-# This info is from config.nmake
-set(MSVC_VARIANT "${CMAKE_GENERATOR}")
-
-# The rc.in requires a plain VERSION variable
-set(VERSION ${PROJECT_VERSION})
-
-# Create the plugin.rc file from the template
-configure_file(plugin.rc.in plugin.rc @ONLY)
+set_module_info(m2m 1 1 0 0)
set(DISSECTOR_SRC
packet-m2m.c
@@ -76,28 +57,10 @@ register_dissector_files(plugin.c
${DISSECTOR_SRC}
)
-add_library(m2m ${LINK_MODE_MODULE}
- ${PLUGIN_FILES}
- ${CMAKE_CURRENT_BINARY_DIR}/plugin.rc
-)
-
-set_target_properties(m2m PROPERTIES
- PREFIX ""
- LINK_FLAGS "${WS_LINK_FLAGS}"
- FOLDER "Plugins"
-)
-
-if(ENABLE_APPLICATION_BUNDLE)
- set_target_properties(m2m PROPERTIES
- LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark
- )
-endif()
-
-target_link_libraries(m2m epan)
+add_plugin_library(m2m)
install(TARGETS m2m
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
-