aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/gryphon/CMakeLists.txt
diff options
context:
space:
mode:
authorKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-09 16:39:34 +0000
committerKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-09 16:39:34 +0000
commit8b8399b7114d9c0202028ec67c4979ad490501b2 (patch)
treeab855999d495b64567e811139941a6750661decc /plugins/gryphon/CMakeLists.txt
parent6d93ca7c961a2ecbc08e53bd0c48e355d388af49 (diff)
Use register_dissector_files in the plugins dissectors
svn path=/trunk/; revision=30435
Diffstat (limited to 'plugins/gryphon/CMakeLists.txt')
-rw-r--r--plugins/gryphon/CMakeLists.txt28
1 files changed, 3 insertions, 25 deletions
diff --git a/plugins/gryphon/CMakeLists.txt b/plugins/gryphon/CMakeLists.txt
index 670d997e5a..dddf7b9087 100644
--- a/plugins/gryphon/CMakeLists.txt
+++ b/plugins/gryphon/CMakeLists.txt
@@ -32,31 +32,9 @@ set(PLUGIN_FILES
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-ADD_CUSTOM_COMMAND(
-# FIXME: Only the Python stuff has been implemented
-# Make this into a MACRO, to avoid duplication with epan/
-#plugin.c: $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
-# $(top_srcdir)/tools/make-dissector-reg.py
-# @if test -n "$(PYTHON)"; then \
-# echo Making plugin.c with python ; \
-# $(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
-# plugin $(DISSECTOR_SRC) ; \
-# else \
-# echo Making plugin.c with shell script ; \
-# $(top_srcdir)/tools/make-dissector-reg $(srcdir) \
-# $(plugin_src) plugin $(DISSECTOR_SRC) ; \
-# fi
-
- OUTPUT plugin.c
- COMMAND ${PYTHON_EXECUTABLE}
- ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg.py
- ${CMAKE_CURRENT_SOURCE_DIR}
- plugin
- ${DISSECTOR_SRC}
- DEPENDS
- ${DISSECTOR_SRC}
- ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg
- ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg.py
+register_dissector_files(plugin.c
+ plugin
+ ${DISSECTOR_SRC}
)
# todo