aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ethercat/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-06 11:55:40 +0100
committerJoão Valverde <j@v6e.pt>2017-09-06 17:26:46 +0000
commitc1ef4693de99e56e182f7e8406f08a734e2e43b5 (patch)
tree74e42cca23d2a5527efa979c25661eac61d35a3a /plugins/ethercat/CMakeLists.txt
parentc6f99aea466319d02006808f35069da7f87a5c1b (diff)
CMake: Make plugin installation path use PLUGIN_INSTALL_LIBDIR
Change-Id: I47f248f6ef56aba400054fa3ade2bf4d29eeb895 Reviewed-on: https://code.wireshark.org/review/23411 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'plugins/ethercat/CMakeLists.txt')
-rw-r--r--plugins/ethercat/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/ethercat/CMakeLists.txt b/plugins/ethercat/CMakeLists.txt
index c697d9bfb1..6955e7f0a8 100644
--- a/plugins/ethercat/CMakeLists.txt
+++ b/plugins/ethercat/CMakeLists.txt
@@ -59,9 +59,9 @@ register_dissector_files(plugin.c
add_plugin_library(ethercat)
install(TARGETS ethercat
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
- RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${PLUGIN_INSTALL_LIBDIR} NAMELINK_SKIP
+ RUNTIME DESTINATION ${PLUGIN_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${PLUGIN_INSTALL_LIBDIR}
)
file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")