aboutsummaryrefslogtreecommitdiffstats
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorStephen Fisher <sfisher@sdf.org>2014-12-19 11:31:07 -0700
committerStephen Fisher <sfisher@sdf.org>2014-12-19 18:33:40 +0000
commitfbd6caa36c1e292ef8a8feccb033371d26d7165d (patch)
tree20afcf508adca3b4a434803422b2f0cb92eb2e95 /help/Makefile.am
parent962fa218ef44593d29f12cab6faf0db02b861ebc (diff)
Take out parenthesis around faq.txt rule so it works when automake
chooses Korn shell instead of Bourne shell. It still works with the Bourne shell in my testing. Change-Id: I00bfed22fb0d9bb183637ea5fb111904b8536949 Reviewed-on: https://code.wireshark.org/review/5880 Reviewed-by: Stephen Fisher <sfisher@sdf.org>
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
index 1a6937aa27..a420b9a9d9 100644
--- a/help/Makefile.am
+++ b/help/Makefile.am
@@ -47,9 +47,9 @@ MAINTAINERCLEANFILES = \
# The output of html2text.py isn't as pretty as elinks, links, or lynx. If that ever changes, we
# can use it exclusively.
faq.txt: $(srcdir)/faq.py
- $(AM_V_GEN)$(srcdir)/faq.py >$@.tmp && \
- (( command -v elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ ) || \
- ( command -v links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ ) || \
- ( command -v lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ ) || \
- $(srcdir)/../tools/html2text.py --width=72 --no-links $@.tmp > $@ ) && \
+ $(AM_V_GEN)$(srcdir)/faq.py >$@.tmp && \
+ command -v elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ || \
+ command -v links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ || \
+ command -v lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ || \
+ $(srcdir)/../tools/html2text.py --width=72 --no-links $@.tmp > $@ && \
rm -f $@.tmp