aboutsummaryrefslogtreecommitdiffstats
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-12-17 19:49:18 +0000
committerGerald Combs <gerald@wireshark.org>2008-12-17 19:49:18 +0000
commitf49377e0e7be6ef7d30ff1dfe685b079ef06249f (patch)
treef9301bcd79a6cdc4b5d9ff541e3fddfe0187aba2 /help/Makefile.am
parent79413d1f89648fe292bd0e42391084d7b2f81b6f (diff)
Update html2text.py to suit our needs. Add spaces in the faq.txt target
so to fix a problem with OS X 10.4. Add html2text.py to the end of the faq.txt target. svn path=/trunk/; revision=27040
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
index 7ae2993a3e..3d3ffe0213 100644
--- a/help/Makefile.am
+++ b/help/Makefile.am
@@ -42,10 +42,12 @@ MAINTAINERCLEANFILES = \
Makefile.in
# Try our best to convert the FAQ to text.
-# Maybe we should use a script (e.g. http://www.aaronsw.com/2002/html2text/) instead.
+# The output of html2text.py isn't as pretty as elinks, links, or lynx. If that ever changes, we
+# can use it exclusively.
faq.txt: $(srcdir)/faq.py
$(srcdir)/faq.py >$@.tmp && \
- (( which elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ )|| \
- ( which links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ )|| \
- ( which lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ ) ) && \
+ (( which elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ ) || \
+ ( which links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ ) || \
+ ( which lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ ) || \
+ $(srcdir)/../tools/html2text.py --width=72 --no-links $@.tmp > $@ ) && \
rm -f $@.tmp