aboutsummaryrefslogtreecommitdiffstats
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2003-12-13 18:05:49 +0000
committerGerald Combs <gerald@wireshark.org>2003-12-13 18:05:49 +0000
commite660fedd31ac127a6d759ac1a95d2257c45ae100 (patch)
tree1233be104d84453fbf7b530e00cada43f5543174 /help/Makefile.am
parent156be8aa9ffc57c5bf08228b2c7d9222b96889a9 (diff)
Add the help directory to the build. Bump the release version to 0.10.0a
svn path=/trunk/; revision=9276
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
new file mode 100644
index 0000000000..74073048e1
--- /dev/null
+++ b/help/Makefile.am
@@ -0,0 +1,48 @@
+# Makefile.am
+# Automake file for Ethereal help files
+#
+# $Id: Makefile.am,v 1.1 2003/12/13 18:05:49 gerald Exp $
+#
+# Ethereal - Network traffic analyzer
+# By Gerald Combs <gerald@ethereal.com>
+# Copyright 2003 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+SUFFIXES = .txt .h
+.txt.h: $(@@:.h=.txt)
+ @ echo making $@
+ @ rm -f $@
+ $(SHELL) convert-include.sh $*
+
+
+BUILT_SOURCES = \
+ capture_filters.h \
+ display_filters.h \
+ faq.h \
+ overview.h \
+ well_known.h
+
+
+helpfile_SOURCES = \
+ capture_filters.txt \
+ display_filters.txt \
+ faq.txt \
+ overview.txt \
+ well_known.txt
+
+EXTRA_DIST = $(BUILT_SOURCES) $(helpfile_SOURCES) convert-include.sh Makefile.nmake
+
+CLEANFILES = $(BUILT_SOURCES)