aboutsummaryrefslogtreecommitdiffstats
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-07-15 13:28:53 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-07-15 13:28:53 +0000
commit9fd357b17488d89210495771d29813c4a20f38d3 (patch)
tree9c5a2d68ce6e23f8ce0e8b2814b7bf1897464171 /help/Makefile.am
parent776c949898e32bd597fadf7d068eb16a23e75df6 (diff)
Fix https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8908 :
As per http://stackoverflow.com/questions/592620/check-if-a-program-exists-from-a-bash-script the portable way to find out if a particular command is available is with "command -v" not "which". svn path=/trunk/; revision=50610
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
index 82c434df95..11b2f9abaf 100644
--- a/help/Makefile.am
+++ b/help/Makefile.am
@@ -6,17 +6,17 @@
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
# Copyright 2003 Gerald Combs
-#
+#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
-#
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -50,8 +50,8 @@ MAINTAINERCLEANFILES = \
# can use it exclusively.
faq.txt: $(srcdir)/faq.py
$(AM_V_GEN)$(srcdir)/faq.py >$@.tmp && \
- (( which elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ ) || \
- ( which links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ ) || \
- ( which lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ ) || \
+ (( command -v elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ ) || \
+ ( command -v links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ ) || \
+ ( command -v lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ ) || \
$(srcdir)/../tools/html2text.py --width=72 --no-links $@.tmp > $@ ) && \
rm -f $@.tmp