aboutsummaryrefslogtreecommitdiffstats
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2015-03-21 11:57:01 +0100
committerAnders Broman <a.broman58@gmail.com>2015-03-25 07:08:52 +0000
commit68698db8ccec8733929752c4b13da71dcad6213e (patch)
tree99f299c4296e94f78038fc8666d987e81a639974 /help/Makefile.am
parent83b6338673d1f1e0035c34021199b90730da73fd (diff)
Always use html2text.py for FAQ, improve output
A recent commit broke compilation with Python 3. The original author of html2text.py is deceased and the fork has increased the number of files for this "simple" helper. The html2text.py script in this patch was rewritten and its output matches with lynx (except for a few newlines around lists). This means that indentation has been added for headings, paragraphs and lists. Also, since it was written from scratch, a new license could be chosen that matches Wireshark. Since now the in-tree html2text.py script provides nicer output, remove detection of the alternative programs (elinks, links). lynx/w3m is somehow still necessary for asciidoc though. (I also looked into reusing html2text.py for the release notes to replace asciidoc, but the --format=html output produces different output (HTML adds a ToC and section numbers). For now still require lynx for release notes) Tested with Python 2.6.6, 2.7.9, 3.2.6 and 3.4.3 under LC_ALL=C and LC_ALL=en_US.UTF-8 on Linux. Tested reading from stdin and file, writing to file, pipe and tty. Tested with cmake (Ninja) and autotools on Arch Linux x86_64. Test: # For each $PATH per python version, execute (with varying LC_ALL) help/faq.py -b | tools/html2text.py /dev/stdin | md5sum help/faq.py -b | tools/html2text.py | md5sum help/faq.py -b | tools/html2text.py help/faq.py -b | tools/html2text.py >/dev/null Change-Id: I6409450a3e6c8b010ca082251f9db7358b0cc2fd Reviewed-on: https://code.wireshark.org/review/7779 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
index a420b9a9d9..ec4da12989 100644
--- a/help/Makefile.am
+++ b/help/Makefile.am
@@ -43,13 +43,8 @@ CLEANFILES = faq.txt
MAINTAINERCLEANFILES = \
Makefile.in
-# Try our best to convert the FAQ to text.
-# The output of html2text.py isn't as pretty as elinks, links, or lynx. If that ever changes, we
-# can use it exclusively.
+# Convert the FAQ to text.
faq.txt: $(srcdir)/faq.py
- $(AM_V_GEN)$(srcdir)/faq.py >$@.tmp && \
- command -v elinks > /dev/null && elinks -dump -dump-width 72 -no-numbering -no-references < $@.tmp > $@ || \
- command -v links > /dev/null && links -width 72 -html-numbered-links 0 -dump $@.tmp > $@ || \
- command -v lynx > /dev/null && lynx -dump -width=72 -nolist -stdin -force-html < $@.tmp > $@ || \
- $(srcdir)/../tools/html2text.py --width=72 --no-links $@.tmp > $@ && \
+ $(AM_V_GEN)$(srcdir)/faq.py -b >$@.tmp && \
+ $(srcdir)/../tools/html2text.py $@.tmp > $@ && \
rm -f $@.tmp