aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2007-04-06 16:15:36 +0000
committerGerald Combs <gerald@wireshark.org>2007-04-06 16:15:36 +0000
commita0afc5d83281995c3b67732b449dacd18c99772e (patch)
tree1f32950673ce9df2e5340dbda5f847ca9140ecf4 /epan/dissectors/Makefile.am
parent85c33a07cb74b9b8ba49ff6c19fe8941f2f41069 (diff)
Add a registration symbol cache to make-dissector-reg.py. When you
update a dissector and recompile, make-dissector-reg.py can now pull its list of registration routines from a cache instead of having to scan through every dissector. The time to create register.c has gone from 20 to 30 seconds down to 2 on my desktop machine. The cache file is a Python pickle data stream. It should be portable across architectures, so we may be able to add it to the distribution at some point. svn path=/trunk/; revision=21348
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index cd7a2358e9..d2a0a9b1ff 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -130,6 +130,8 @@ register.c: $(plugin_src) $(ALL_DISSECTORS_SRC) $(top_srcdir)/tools/make-dissect
#dist-hook:
# @rm -f $(distdir)/register.c
+# XXX - We may want to add register-cache.pkl to the distribution at
+# some point. It should be portable across architectures.
CLEANFILES = \
libcleandissectors.a \
libcleandissectors.la \
@@ -140,6 +142,7 @@ CLEANFILES = \
libpidldissectors.la \
libpidldissectors.a \
register.c-tmp \
+ register-cache.pkl \
$(GENERATED_HEADER_FILES) \
*~