aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorstandel <standel@f5534014-38df-0310-8fa8-9805f1628bb7>2007-04-03 19:50:04 +0000
committerstandel <standel@f5534014-38df-0310-8fa8-9805f1628bb7>2007-04-03 19:50:04 +0000
commit29c870727bbd4978a4886fde71c0967af1935d65 (patch)
tree83c23d84f562b2b9e8cbf3c5542c9f3499164ad0 /epan/dissectors/Makefile.am
parent44935e00e61cb712e1771e692aaeea59c01599f7 (diff)
epan/dissectors/Makefile is now building four libraries :
- asn dissectors : libasndissectors.la - pidl dissectors : libpidldissectors.la - normal dissectors : libdissectors.la *and* libcleandissectors.la. I separated it in two libraries temporarily. The source files used to build libcleandissectors.la do not generate warning anymore and the -Werror is used to compile them. If we patch a dissector and it doesn't generate warning anymore, we have to move the filename dissector from DISSECTOR_SRC to CLEAN_DISSECTOR_SRC in epan/dissectors/Makefile.common. If you want to define specific cflags for one library type, let's say pidl, you may define libpidldissectors_la_CFLAGS. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@21324 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am32
1 files changed, 28 insertions, 4 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index 5c87c49b6c..972fc04ba9 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -20,17 +20,34 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-noinst_LTLIBRARIES = libdissectors.la
+noinst_LTLIBRARIES = libdissectors.la libcleandissectors.la libasndissectors.la libpidldissectors.la
+
+
INCLUDES = -I$(srcdir)/../.. -I$(srcdir)/.. \
$(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS)
include Makefile.common
+
+libasndissectors_la_SOURCES = \
+ $(ASN_DISSECTOR_SRC)
+
+libpidldissectors_la_SOURCES = \
+ $(PIDL_DISSECTOR_SRC)
+
libdissectors_la_SOURCES = \
$(DISSECTOR_SRC) \
$(DISSECTOR_SUPPORT_SRC)
+if HAVE_WARNINGS_AS_ERRORS
+AM_CLEAN_CFLAGS = -Werror
+endif
+libcleandissectors_la_SOURCES = \
+ $(CLEAN_DISSECTOR_SRC)
+libcleandissectors_la_CFLAGS = $(AM_CLEAN_CFLAGS)
+
+
EXTRA_DIST = \
Makefile.common \
Makefile.nmake \
@@ -89,13 +106,14 @@ register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-re
@if test -n $(PYTHON); then \
echo Making register.c with python ; \
$(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
- dissectors $(DISSECTOR_SRC) ; \
+ dissectors $(DISSECTOR_SRC) $(CLEAN_DISSECTOR_SRC) \
+ $(PIDL_DISSECTOR_SRC) $(ASN_DISSECTOR_SRC) ; \
else \
echo Making register.c with shell script ; \
$(top_srcdir)/tools/make-dissector-reg $(srcdir) \
- dissectors $(plugin_src) $(DISSECTOR_SRC) ; \
+ dissectors $(plugin_src) $(DISSECTOR_SRC) $(CLEAN_DISSECTOR_SRC) \
+ $(PIDL_DISSECTOR_SRC) $(ASN_DISSECTOR_SRC) ; \
fi
-
#
# Currently register.c can be included in the distribution because
# we always build all protocol dissectors. We used to have to check
@@ -115,8 +133,14 @@ register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-re
# @rm -f $(distdir)/register.c
CLEANFILES = \
+ libcleandissectors.a \
+ libcleandissectors.la \
libdissectors.a \
libdissectors.la \
+ libasndissectors.la \
+ libasndissectors.a \
+ libpidldissectors.la \
+ libpidldissectors.a \
register.c-tmp \
$(GENERATED_HEADER_FILES) \
*~