aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2000-10-16 23:18:05 +0000
committerGuy Harris <guy@alum.mit.edu>2000-10-16 23:18:05 +0000
commitcba377df3c5bb5c4920eac87041d4a52246babd7 (patch)
tree29f50f9b0aa9fdf3db85139eb7a63357c9a4c298 /epan/Makefile.am
parentcb0a63c8e77464c022e40dc1b25c5aeb2a4c1ba6 (diff)
Give libethereal its own configuration file, and have that configuration
file, rather than the top-level Ethereal configuration file, check for "inet_aton()", "inet_pton()", and "inet_ntop()". Then make its Makefile.am include the appropriate object files if necessary. Otherwise, they don't get built and put into libethereal, and therefore attempts to link with anything in libethereal that uses them fail on platforms that lack ethem, causing the build to fail. That means a bunch of things need to be fixed to cope with libethereal having its own "config.h" file; this means removing the include of "config.h" from some libethereal header files. Move the definitions of the path names used only by "resolv.c" to "resolv.c" from "resolv.h" (so "resolv.h" doesn't need "config.h", define HAVE_PLUGINS in the configure script (so we don't have to include it in "plugins.h" to check whether HAVE_DLFCN_H is defined). Unfortunately, stuff outside libethereal needs to know PLUGIN_DIR; for now, define that in the top-level configuration file, and have Ethereal and Tethereal pass it as an argument to "epan_init()" - that should be cleaned up at some point. Remove from the top-level configure script checks for things used only in libethereal. svn path=/trunk/; revision=2498
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index fe5519064a..5d12aeeac1 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for the EPAN library
# (Ethereal Protocol ANalyzer Library)
#
-# $Id: Makefile.am,v 1.9 2000/10/14 04:31:25 gram Exp $
+# $Id: Makefile.am,v 1.10 2000/10/16 23:17:39 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -30,8 +30,11 @@ YFLAGS=-d -p dfilter_
# EPAN will eventually be a shared library. While I move source code around,
# however, it is an archive library.
+ACLOCAL_AMFLAGS = `../aclocal-flags`
+
noinst_LIBRARIES = libethereal.a
+INCLUDES = -I$(srcdir)/..
libethereal_a_SOURCES = \
conversation.c \
@@ -82,6 +85,12 @@ CLEANFILES = \
libethereal.a \
*~
+#
+# Add the object files for missing routines, if any.
+#
+libethereal_a_LIBADD = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+libethereal_a_DEPENDENCIES = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+
dfilter-scanner.c : dfilter-scanner.l
$(LEX) -Pdfilter_ -odfilter-scanner.c $(srcdir)/dfilter-scanner.l