aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2000-11-15 09:37:53 +0000
committerGuy Harris <guy@alum.mit.edu>2000-11-15 09:37:53 +0000
commit2fa39ce7d3894c64a095e5993b7a03a2f19eca6c (patch)
treecc840dabed09a465cdf8b82fb24afd6349a698f0 /epan/Makefile.am
parentb606de7ea39043b9c1323283e00bc6493613f4dd (diff)
Move the table of bit-swapped byte values to "epan/bitswap.c", and
declare it, and define a "BIT_SWAP" macro that uses it, in "epan/bitswap.h". Use that macro to bit-swap bytes in the IEEE 802.11 dissector, rather than the macro that was used (said macro used GCCisms and didn't compile on Windows). Make an "init_plugin()" routine to enable a plugin and call its init routine, and call it from "check_plugin_status()" and "plugins_enable_cb()", rather than having very similar code in two places; "patable" is now part of libethereal, and, at least on Windows, attempts to refer to it from "libui" failed. Make "patable" static to "epan/plugins.c". (This may still not work, as now "libui" is calling a routine in "libethereal"; if that fails, perhaps it's time to get rid of the "enable/disable plugins" stuff completely, as new-style plugins, at least, register themselves as protocols and should be controllable from the "Edit->Protocols" window just as built-in dissectors are.) svn path=/trunk/; revision=2649
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index d637180dac..b53a95d0fb 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for the EPAN library
# (Ethereal Protocol ANalyzer Library)
#
-# $Id: Makefile.am,v 1.12 2000/10/19 07:18:19 guy Exp $
+# $Id: Makefile.am,v 1.13 2000/11/15 09:37:51 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -37,6 +37,8 @@ noinst_LIBRARIES = libethereal.a
INCLUDES = -I$(srcdir)/..
libethereal_a_SOURCES = \
+ bitswap.c \
+ bitswap.h \
conversation.c \
conversation.h \
dfilter-int.h \