aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-03 21:32:53 +0000
committerJoão Valverde <j@v6e.pt>2016-04-17 01:37:55 +0000
commit173ccf7a4664de8001ce92966ae0c68e7805e9b4 (patch)
treeab9001adb43820eeb5904ead2e4c7cf91c8a280e /epan/Makefile.am
parent597343bcf4f9a612e522c4fea76f55bbc9ecc1de (diff)
More test-programs autotoolizing
Change-Id: I3e16dc8c591352f19bba190d84a6ed3fe431e21f Reviewed-on: https://code.wireshark.org/review/14926 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 25c4eec0f5..a7af0d83a2 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -86,11 +86,7 @@ EXTRA_DIST = \
Makefile.common \
Makefile.nmake \
radius_dict.l \
- tvbtest.c \
- reassemble_test.c \
uat_load.l \
- exntest.c \
- oids_test.c \
doxygen.cfg.in \
CMakeLists.txt \
print.ps
@@ -160,7 +156,8 @@ libwireshark_la_DEPENDENCIES = \
${top_builddir}/wsutil/libwsutil.la \
${top_builddir}/wiretap/libwiretap.la
-EXTRA_PROGRAMS = reassemble_test tvbtest oids_test
+EXTRA_PROGRAMS = reassemble_test tvbtest oids_test exntest
+
reassemble_test_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
@@ -176,11 +173,12 @@ oids_test_LDADD = \
$(GLIB_LIBS) \
-lz
-exntest: exntest.o except.o
- $(LINK) $^ $(GLIB_LIBS)
+exntest_SOURCES = exntest.c except.c
+
+exntest_LDADD = $(GLIB_LIBS)
-test-programs: $(EXTRA_PROGRAMS) exntest
- cd wmem && $(MAKE) $@
+test-programs: $(EXTRA_PROGRAMS)
+ $(MAKE) -C wmem $@
diam_dict_lex.h: diam_dict.c