aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-20 23:51:12 +0100
committerJoão Valverde <j@v6e.pt>2016-04-22 22:10:30 +0000
commit5d1ee652eda00fa8a5a8fc4c72e4313f8966a3bd (patch)
tree4dd5b8a3f06d8b75abdd12e8f37607a295618c78 /epan/CMakeLists.txt
parent341c2dfdb6e635a1456230092a7fe51ff4651864 (diff)
Add CMake version.h dependency
Remove the need for version.h.in and bring CMake up to par with autotools. Change-Id: I701b56c475f5fdec1f9a028536fff6992ce8eaca Reviewed-on: https://code.wireshark.org/review/15031 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 33d63a6c02..4c7d375e12 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -231,6 +231,8 @@ add_library(epan ${LINK_MODE_LIB}
${CMAKE_BINARY_DIR}/image/libwireshark.rc
)
+add_dependencies(epan version)
+
set(FULL_SO_VERSION "0.0.0")
set_target_properties(epan PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")