aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Canet <benoit@scylladb.com>2016-09-26 16:25:11 +0200
committerPascal Quantin <pascal.quantin@gmail.com>2016-10-17 18:28:45 +0000
commit47649d1c7fb6ba48b805e19268a711404eb6908b (patch)
tree603eea5969a564511df482a2d8d6a9525cfea74b /epan/CMakeLists.txt
parent5c42d8a24c863549166bc1d0875e87a07bedf53e (diff)
cql: add lz4 and snappy decompression
We do not use the STARTUP negotiation since a stream can be captured in its middle but try to decompress if the flag is present and fallback if it fails. Change-Id: Iecbf49a45220b04be7808869c9884548eb1e7694 Signed-off-by: Benoît Canet <benoit@scylladb.com> Reviewed-on: https://code.wireshark.org/review/17952 Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 4e48ff56b3..3bb415589c 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -189,17 +189,19 @@ add_lemon_files(LEMON_FILES GENERATED_FILES
set(epan_LIBS
wiretap
wsutil
- ${GLIB2_LIBRARIES}
- ${PCAP_LIBRARIES}
${CARES_LIBRARIES}
- ${KERBEROS_LIBRARIES}
- ${GEOIP_LIBRARIES}
${GCRYPT_LIBRARIES}
+ ${GEOIP_LIBRARIES}
+ ${GLIB2_LIBRARIES}
${GNUTLS_LIBRARIES}
- ${SMI_LIBRARIES}
+ ${KERBEROS_LIBRARIES}
+ ${LUA_LIBRARIES}
+ ${LZ4_LIBRARIES}
${M_LIBRARIES}
${NGHTTP2_LIBRARIES}
- ${LUA_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ ${SMI_LIBRARIES}
+ ${SNAPPY_LIBRARIES}
${WIN_PSAPI_LIBRARY}
)