aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-19 08:03:08 +0100
committerJoão Valverde <j@v6e.pt>2016-04-21 18:59:56 +0000
commit3db13a7fc9f08fdb238f06e73a42b39396fee84c (patch)
tree13962d67e01b8d0f15aed5e6216ae584c23bd991 /epan/CMakeLists.txt
parent7c6e859ccf210a45e1cc0f6da17692845e6b5a23 (diff)
Link version code statically again
This allows keeping the code-sharing with the static linking. This "fixes" a hypothetical ABI mismatch with wsutil and avoids pulling more external dependencies to wsutil than strictly necessary. A nice side-effect is that libwsutil no longer depends on version.h. Follow up to f95976eefcbeb5d24df383c29d29ef888b503945. Change-Id: I8f0d6a557ab3f7ce6f0e2c269124c89f29d6ad23 Reviewed-on: https://code.wireshark.org/review/15002 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 82d0169d3e..33d63a6c02 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -168,6 +168,7 @@ set(LIBWIRESHARK_FILES
uat.c
value_string.c
xdlc.c
+ ${CMAKE_SOURCE_DIR}/ws_version_info.c
)
set(LIBWIRESHARK_CLEAN_FILES