aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2016-03-11 19:51:39 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2016-05-02 12:01:24 +0000
commit2e23b506c766d98966ed213c760b2aa6232ba1fe (patch)
treee15eec1049e10419d869dea459730791ec2bc128 /epan/CMakeLists.txt
parent231f6b5035e4f001eca22029b58cf4c498d624bd (diff)
Add checkAPI calls to CMake.
This generates a top level target, checkAPI, that is excluded from the ALL build target, so must be run separately. On Windows using a Visual Studio generator, call msbuild /p:Configuration=RelWithDebInfo checkAPI.vcxproj Change-Id: I44a57c564dcfc75499463b942436f4b920a82478 Reviewed-on: https://code.wireshark.org/review/14873 Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt17
1 files changed, 15 insertions, 2 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 4c7d375e12..fec80d289a 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -175,7 +175,7 @@ set(LIBWIRESHARK_CLEAN_FILES
${LIBWIRESHARK_FILES}
)
-add_lex_files(LIBWIRESHARK_FILES
+add_lex_files(LEX_FILES GENERATED_FILES
diam_dict.l
dtd_parse.l
dtd_preparse.l
@@ -183,7 +183,7 @@ add_lex_files(LIBWIRESHARK_FILES
uat_load.l
)
-add_lemon_files(LIBWIRESHARK_FILES
+add_lemon_files(LEMON_FILES GENERATED_FILES
dtd_grammar.lemon
)
@@ -219,6 +219,7 @@ endif()
add_library(epan ${LINK_MODE_LIB}
${LIBWIRESHARK_FILES}
+ ${GENERATED_FILES}
${COMPRESS_FILES}
${LIBWIRESHARK_ASM_FILES}
$<TARGET_OBJECTS:crypt>
@@ -341,6 +342,18 @@ set_target_properties(tvbtest PROPERTIES
COMPILE_DEFINITIONS "WS_BUILD_DLL"
)
+# Commented out as per nmake
+#CHECKAPI(
+# NAME
+# epan
+# SWITCHES
+# -g termoutput -build
+# SOURCES
+# ${LIBWIRESHARK_FILES}
+# ${LEX_FILES}
+# ${LEMON_FILES}
+#)
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#