aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-05-10 11:59:44 +0200
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2016-05-10 11:51:21 +0000
commit850411dd440642074ead15d5f734fa4743940de0 (patch)
treef077a41e596130fb55faf1377edb4896255de8cd /epan/CMakeLists.txt
parent49362062e3a22a0b9c9e0b2a25a1f7a89a736732 (diff)
cmake: fix build without Lua
Fixes this error: Objects of target "wslua" referenced but no such target exists. Change-Id: I1168dbff538fb62f614073c28aaba6e6666f499b Reviewed-on: https://code.wireshark.org/review/15329 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Léo Gaspard Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 1e17bbadc1..73d2201d22 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -218,6 +218,13 @@ if (WERROR_COMMON_FLAGS)
)
endif()
+# Cannot use $<$<BOOL:${HAVE_LIBLUA}>:$<TARGET_OBJECTS:wslua>> as that breaks
+# get_target_property(_libwireshark_location epan LOCATION).
+if(HAVE_LIBLUA)
+ set(wslua_sources $<TARGET_OBJECTS:wslua>)
+else()
+ set(wslua_sources)
+endif()
add_library(epan ${LINK_MODE_LIB}
${LIBWIRESHARK_FILES}
${GENERATED_FILES}
@@ -229,7 +236,7 @@ add_library(epan ${LINK_MODE_LIB}
$<TARGET_OBJECTS:ftypes>
$<TARGET_OBJECTS:nghttp2>
$<TARGET_OBJECTS:wmem>
- $<TARGET_OBJECTS:wslua>
+ ${wslua_sources}
${CMAKE_BINARY_DIR}/image/libwireshark.rc
)