aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-10-11 07:32:51 +0000
committerJörg Mayer <jmayer@loplof.de>2009-10-11 07:32:51 +0000
commite00a9ba112858f08c38c9c54c2be96e4a93f5970 (patch)
tree38b87b2e5b4ecaaca2a685fc28378854c02585c2 /epan/CMakeLists.txt
parentec7380a6b1684d35c5d8da83f1f38c1b6d6dceb5 (diff)
Readd stuff "lost" by previous undo (r30443, r30459)
svn path=/trunk/; revision=30495
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 1f89a60fd3..723a952bac 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -90,6 +90,14 @@ add_lemon_files(DFILTER_FILES
dfilter/grammar.lemon
)
+if (AUTOGEN_dcerpc)
+ add_subdirectory( dcerpc )
+endif()
+
+if (AUTOGEN_pidl)
+ add_subdirectory( pidl )
+endif()
+
ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/packet-ncp2222.c
COMMAND ${PYTHON_EXECUTABLE}
@@ -1002,7 +1010,7 @@ set(DISSECTOR_SUPPORT_SRC
register.c
)
-set(DISSECTOR_ASM_UTILS
+set(LIBWIRESHARK_ASM_FILES
asm_utils.c
# !IFDEF NASM
# asm_utils_win32_x86.obj: asm_utils_win32_x86.asm
@@ -1025,12 +1033,12 @@ set(DISSECTOR_FILES
)
set_source_files_properties(
- ${DISSECTOR_SRC}
+ ${DISSECTOR_SRC}
${PIDL_DISSECTOR_SRC}
${ASN1_DISSECTOR_SRC}
PROPERTIES
# FIXME: -Werror and -pedantic exclude each other: test for -pedantic
- # COMPILE_FLAGS -Werror
+ # COMPILE_FLAGS -Werror
)
register_dissector_files(register.c
@@ -1183,7 +1191,7 @@ add_library(epan SHARED
${FTYPE_FILES}
${DISSECTOR_FILES}
${DISSECTOR_SUPPORT_SRC}
- ${DISSECTOR_ASM_UTILS}
+ ${LIBWIRESHARK_ASM_FILES}
)
# In case we want the libwireshark name back
# SET_TARGET_PROPERTIES(epan PROPERTIES OUTPUT_NAME "wireshark")