aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-11-17 11:58:36 +0000
committerJörg Mayer <jmayer@loplof.de>2009-11-17 11:58:36 +0000
commitd2cc318f4fc184a3de6038d1492896ec6bfb5f79 (patch)
treec635034c45104971ecf947a800fa3815dc2671a2 /epan/CMakeLists.txt
parent9c06ca976e94c1a89fbc28fa3930966b395ff07c (diff)
Beginnings of enabling static builds. Still to do:
* Add -static * Registration may need different handling * Add plugins * Build error in wslua svn path=/trunk/; revision=30987
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index d452f423c8..42692d6f68 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -1253,7 +1253,7 @@ if (WERROR)
)
endif()
-add_library(epan SHARED
+add_library(epan ${LINK_MODE_LIB}
# Needed to trigger build of the include files for x11
#x11-declarations.h
#x11-register-info.h
@@ -1279,9 +1279,11 @@ target_link_libraries(epan ${epan_LIBS})
add_dependencies(epan lemon)
-install(TARGETS epan
- LIBRARY DESTINATION lib
- RUNTIME DESTINATION lib
- ARCHIVE DESTINATION lib
-)
+if(NOT ${ENABLE_STATIC})
+ install(TARGETS epan
+ LIBRARY DESTINATION lib
+ RUNTIME DESTINATION lib
+ ARCHIVE DESTINATION lib
+ )
+endif()