aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey Smith <whydoubt@gmail.com>2015-08-18 22:03:41 -0500
committerAnders Broman <a.broman58@gmail.com>2015-09-11 06:31:33 +0000
commit80322d88da92969c170c915e93a33a96e12497a7 (patch)
tree516e0c526cda1291b5c2a376d40f4fb80b6ddc98 /epan/CMakeLists.txt
parent86d8b8d7bfd3c76d646907d5549e552519ea8261 (diff)
dfilter: Add membership operator
Added a new relational test: 'x in {a b c}'. The only LHS entity supported at this time is a field. The generated DFVM operations are equivalent to an OR'ed series of =='s, but with the redundant existence tests removed. Change-Id: Iddc89b81cf7ad6319aef1a2a94f93314cb721a8a Reviewed-on: https://code.wireshark.org/review/10246 Reviewed-by: Hadriel Kaplan <hadrielk@yahoo.com> Petri-Dish: Hadriel Kaplan <hadrielk@yahoo.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 4731c81915..9950b8dcc7 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -76,6 +76,7 @@ set(DFILTER_FILES
dfilter/sttype-integer.c
dfilter/sttype-pointer.c
dfilter/sttype-range.c
+ dfilter/sttype-set.c
dfilter/sttype-string.c
dfilter/sttype-test.c
dfilter/syntax-tree.c