aboutsummaryrefslogtreecommitdiffstats
path: root/echld/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2017-03-19 13:47:11 +0100
committerAnders Broman <a.broman58@gmail.com>2017-03-19 15:13:14 +0000
commit0b6b152694762bd5783569acbae48e9397d2b85f (patch)
tree4a26a51846b33e8d8182be87e25df3dfdab8cfcf /echld/CMakeLists.txt
parenta65c0c457668d7524dffefb17cc4e69a77a29f3c (diff)
Remove echld/.
It has been unsupported for some years and when talking about removing it in the past I received some positive and no negative feedback. There is one instance of echld left: capchild/capture_sync.c: * echld might have already reaped the child. Can that case be removed or should be comment be updated to something more accurate? (left for a separate patch) Change-Id: Idac397158dd86fd0728eb95379449ee4a463fc28 Reviewed-on: https://code.wireshark.org/review/20619 Petri-Dish: Jörg Mayer <jmayer@loplof.de> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'echld/CMakeLists.txt')
-rw-r--r--echld/CMakeLists.txt106
1 files changed, 0 insertions, 106 deletions
diff --git a/echld/CMakeLists.txt b/echld/CMakeLists.txt
deleted file mode 100644
index 37db17fa68..0000000000
--- a/echld/CMakeLists.txt
+++ /dev/null
@@ -1,106 +0,0 @@
-# CMakeLists.txt
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-
-set(CLEAN_FILES
- echld-util.c
- parent.c
-)
-
-set(DIRTY_FILES
- child.c
- common.c
- dispatcher.c
-)
-
-set(echld_LIBS
- ${GLIB2_LIBRARIES}
-)
-
-set(ECHLD_FILES
- ${CLEAN_FILES}
- ${DIRTY_FILES}
-)
-
-set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
-)
-
-
-add_library(echld ${LINK_MODE_LIB}
- ${ECHLD_FILES}
-)
-
-set(FULL_SO_VERSION "0.0.0")
-
-set_target_properties(echld PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")
-set_target_properties(echld PROPERTIES COMPILE_OPTIONS "${WS_WARNINGS_C_FLAGS}")
-set_target_properties(echld PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
-set_target_properties(echld PROPERTIES VERSION ${FULL_SO_VERSION} SOVERSION 0)
-
-# discover and substitute list of include directories for ABI compatibility
-# checks
-#get_directory_property(INCLUDE_DIRS INCLUDE_DIRECTORIES)
-#list(REMOVE_DUPLICATES INCLUDE_DIRS)
-#string(REGEX REPLACE ";" "\n" INCLUDE_DIRS "${INCLUDE_DIRS}")
-#configure_file(../abi-descriptor.template abi-descriptor.xml)
-
-# ABI compliance checker can be obtained from
-# http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
-# Checked using version 1.21.12
-#file(GLOB HEADERS *.h)
-#file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/abi-check-headers)
-#
-#file(COPY ${HEADERS} ../ws_symbol_export.h DESTINATION abi-check-headers)
-
-#add_custom_command(OUTPUT libwsutil.abi.tar.gz
-# COMMAND cp ../config.h abi-check-headers/
-# COMMAND abi-compliance-checker -l libwsutil -v1 ${FULL_SO_VERSION}
-# -relpath ${CMAKE_CURRENT_BINARY_DIR} -dump-abi abi-descriptor.xml
-# || cat logs/libwsutil/[0-9]*/log.txt
-# COMMAND cp abi_dumps/libwsutil/libwsutil_* libwsutil.abi.tar.gz
-# COMMAND rm -rf abi-check-headers/* abi_dumps
-# DEPENDS ${HEADERS} wsutil)
-#add_custom_target(dumpabi-libwsutil DEPENDS libwsutil.abi.tar.gz)
-
-target_link_libraries(echld ${echld_LIBS})
-
-if(NOT ${ENABLE_STATIC})
- install(TARGETS echld
- LIBRARY DESTINATION lib
- RUNTIME DESTINATION lib
- ARCHIVE DESTINATION lib
- )
-endif()
-
-#
-# Editor modelines - http://www.wireshark.org/tools/modelines.html
-#
-# Local variables:
-# c-basic-offset: 8
-# tab-width: 8
-# indent-tabs-mode: t
-# End:
-#
-# vi: set shiftwidth=8 tabstop=8 noexpandtab:
-# :indentSize=8:tabSize=8:noTabs=false:
-#