aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-01-24 01:10:10 +0000
committerGerald Combs <gerald@wireshark.org>2014-01-24 01:10:10 +0000
commita9ddc06adc436d8ca4a9d97af95969d4ff01adf8 (patch)
treec99d7ac711dbca4abab20138012e7c563be7c7d9 /docbook/Makefile.am
parent81f3392d329306800f3e5cdd39c42395a3cdacdf (diff)
Prepare for conversion of Guide chapters to AsciiDoc.
svn path=/trunk/; revision=54936
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index 03079a6c16..164b3d7786 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -55,6 +55,15 @@ else
@false
endif
+# Convert an AsciiDoc document to a Docbook chapter
+.asciidoc.xml:
+ $(A2X) --verbose \
+ --asciidoc-opts="--conf-file=asciidoc.conf" \
+ --no-xmllint \
+ --format=docbook --doctype=book \
+ $<
+ mv $*.xml $*.dbk
+ xmllint --xpath chapter $*.dbk > $@
if HAVE_XSLTPROC
ALL_TARGETS=git_version_check wsug wsdg release_notes
@@ -233,6 +242,8 @@ release-notes.txt: $(RELEASE_NOTES_SOURCE)
news: release-notes.txt
cp release-notes.txt ../NEWS
+# Apparently we can only run one instance of a2x at a time.
+.NOTPARALLEL: release-notes-us.pdf release-notes-a4.pdf
# create pdf file, portrait pages on US letter paper
release-notes-us.pdf: $(RELEASE_NOTES_SOURCE) custom_layer_pdf.xsl
@ echo --- RELEASE NOTES - PDF US LETTER PAPER ---