aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-05 18:31:11 +0100
committerMichael Mann <mmann78@netscape.net>2015-12-22 12:24:16 +0000
commitac0eb6043be787428a194c163b55c852c8cb5be2 (patch)
tree74a195f4a020453d811127323e95da2ef80627d6 /doc/Makefile.am
parent0e4a7429db488b25941be4aa66405f9c2f4915e5 (diff)
extcap: add randpktdump, a random packet generator.
This new extcap is for testing and educational purpose. It relies on rankpkt-core functions to generate random packets. Change-Id: If6890f0673545682995a2079458108edc0913b30 Reviewed-on: https://code.wireshark.org/review/11764 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 1c4381ec23..6ad7e41c14 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -72,7 +72,9 @@ man1_MANS = \
@dftest_man@ \
@randpkt_man@ \
@androiddump_man@ \
- @sshdump_man@
+ @sshdump_man@ \
+ @randpktdump_man@
+
man4_MANS = @wiresharkfilter_man@
man_MANS =
@@ -84,7 +86,7 @@ noinst_DATA = asn2deb.1 asn2deb.html idl2deb.1 idl2deb.html idl2wrs.1 idl2wrs.ht
pkgdata_DATA = AUTHORS-SHORT $(top_srcdir)/docbook/ws.css wireshark.html \
tshark.html wireshark-filter.html capinfos.html editcap.html \
mergecap.html reordercap.html text2pcap.html dumpcap.html androiddump.html \
- sshdump.html rawshark.html dftest.html randpkt.html
+ sshdump.html randpktdump.html rawshark.html dftest.html randpkt.html
#
# Build the short version of the authors file for the about dialog
@@ -220,6 +222,13 @@ sshdump.html: sshdump.pod ../config.h $(top_srcdir)/docbook/ws.css
--noindex \
$(srcdir)/sshdump.pod > sshdump.html
+randpktdump.html: randpktdump.pod ../config.h $(top_srcdir)/docbook/ws.css
+ $(AM_V_POD2HTML)$(POD2HTML) \
+ --title="randpktdump - The Wireshark Network Analyzer $(VERSION)" \
+ --css=$(POD_CSS_URL) \
+ --noindex \
+ $(srcdir)/randpktdump.pod > randpktdump.html
+
rawshark.html: rawshark.pod ../config.h $(top_srcdir)/docbook/ws.css
$(AM_V_POD2HTML)$(POD2HTML) \
--title="rawshark - The Wireshark Network Analyzer $(VERSION)" \