aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-08-10 10:20:30 -0700
committerMichael Mann <mmann78@netscape.net>2017-08-12 13:53:59 +0000
commit537b083e028c636b8f8afc4a847e186f4abca59f (patch)
treee46fdbe05f81b850d6f31d125e5353d558d4e906 /doc/CMakeLists.txt
parentdc2a2424b48086ac2f79abc322070a4498d01607 (diff)
Sync some CMake and Autotools install behaviors.
Adjust the following CMake and Autotools behaviors in order to synchronize their respective install behaviors: - Disable tfshark by default in CMakeOptions.txt - Add profiles/Bluetooth/preferences to Makefile.am - Add missing captype and ciscodump entries to doc/Makefile.am - Install help/faq.txt on all platforms in CMakeLists.txt - Add BUILD_corbaidl2wrs, BUILD_dcerpcidl2wrs, and BUILD_xxx2deb options to CMake and use them to adjust the corresponding parts of the build. - Pull the DCERPC idl2wrs build steps into the top-level CMakeLists.txt. This change doesn't sync everything. Some installed content still diverges, including the following: - CMake installs a bunch of modules into lib/wireshark: FindGLIB2.cmake FindWireshark.cmake FindWSWinLibs.cmake LocatePythonModule.cmake UseAsn2Wrs.cmake UseMakeDissectorReg.cmake WiresharkConfig.cmake WiresharkConfigVersion.cmake Do we need any or all of these? If so, should the Autotools behavior be synced accordingly? - Autotools installs libtool .la files. It also installs wireshark-gtk.desktop unconditionally. Change-Id: I7846efe08f7139c31b6ceca6f08a1fa5168b3e22 Reviewed-on: https://code.wireshark.org/review/23041 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt37
1 files changed, 28 insertions, 9 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index cbb2f5bdd3..ef0e90a2e1 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -70,15 +70,12 @@ else()
endif()
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/androiddump 1)
-pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/asn2deb 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/udpdump 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/capinfos 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/captype 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/dftest 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/dumpcap 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/editcap 1)
-pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/idl2deb 1)
-pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/idl2wrs 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/mergecap 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/randpkt 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/randpktdump 1)
@@ -93,8 +90,15 @@ pod2manhtml(${CMAKE_CURRENT_BINARY_DIR}/wireshark 1)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/extcap 4)
pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/wireshark-filter 4)
+if (BUILD_corbaidl2wrs)
+ pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/idl2wrs 1)
+endif()
+if (BUILD_xxx2deb)
+ pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/asn2deb 1)
+ pod2manhtml(${CMAKE_CURRENT_SOURCE_DIR}/idl2deb 1)
+endif()
+
set(MAN1_INSTALL_FILES
- ${CMAKE_CURRENT_BINARY_DIR}/asn2deb.1
${CMAKE_CURRENT_BINARY_DIR}/androiddump.1
${CMAKE_CURRENT_BINARY_DIR}/udpdump.1
${CMAKE_CURRENT_BINARY_DIR}/capinfos.1
@@ -103,8 +107,6 @@ set(MAN1_INSTALL_FILES
${CMAKE_CURRENT_BINARY_DIR}/dftest.1
${CMAKE_CURRENT_BINARY_DIR}/dumpcap.1
${CMAKE_CURRENT_BINARY_DIR}/editcap.1
- ${CMAKE_CURRENT_BINARY_DIR}/idl2deb.1
- ${CMAKE_CURRENT_BINARY_DIR}/idl2wrs.1
${CMAKE_CURRENT_BINARY_DIR}/mergecap.1
${CMAKE_CURRENT_BINARY_DIR}/randpkt.1
${CMAKE_CURRENT_BINARY_DIR}/randpktdump.1
@@ -117,6 +119,16 @@ set(MAN1_INSTALL_FILES
${CMAKE_CURRENT_BINARY_DIR}/wireshark.1
)
+if (BUILD_corbaidl2wrs)
+ list(APPEND MAN1_INSTALL_FILES ${CMAKE_CURRENT_BINARY_DIR}/idl2wrs.1)
+endif()
+if (BUILD_xxx2deb)
+ list(APPEND MAN1_INSTALL_FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/asn2deb.1
+ ${CMAKE_CURRENT_BINARY_DIR}/idl2deb.1
+ )
+endif()
+
set(MAN4_INSTALL_FILES
${CMAKE_CURRENT_BINARY_DIR}/extcap.4
${CMAKE_CURRENT_BINARY_DIR}/wireshark-filter.4
@@ -131,7 +143,6 @@ add_custom_target(manpages DEPENDS
)
set(HTML_INSTALL_FILES
- ${CMAKE_CURRENT_BINARY_DIR}/asn2deb.html
${CMAKE_CURRENT_BINARY_DIR}/androiddump.html
${CMAKE_CURRENT_BINARY_DIR}/udpdump.html
${CMAKE_CURRENT_BINARY_DIR}/capinfos.html
@@ -141,8 +152,6 @@ set(HTML_INSTALL_FILES
${CMAKE_CURRENT_BINARY_DIR}/dumpcap.html
${CMAKE_CURRENT_BINARY_DIR}/editcap.html
${CMAKE_CURRENT_BINARY_DIR}/extcap.html
- ${CMAKE_CURRENT_BINARY_DIR}/idl2deb.html
- ${CMAKE_CURRENT_BINARY_DIR}/idl2wrs.html
${CMAKE_CURRENT_BINARY_DIR}/mergecap.html
${CMAKE_CURRENT_BINARY_DIR}/randpkt.html
${CMAKE_CURRENT_BINARY_DIR}/randpktdump.html
@@ -156,6 +165,16 @@ set(HTML_INSTALL_FILES
${CMAKE_CURRENT_BINARY_DIR}/wireshark-filter.html
)
+if (BUILD_corbaidl2wrs)
+ list(APPEND HTML_INSTALL_FILES ${CMAKE_CURRENT_BINARY_DIR}/idl2wrs.html)
+endif()
+if (BUILD_xxx2deb)
+ list(APPEND HTML_INSTALL_FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/asn2deb.html
+ ${CMAKE_CURRENT_BINARY_DIR}/idl2deb.html
+ )
+endif()
+
add_custom_target(
docs ALL
DEPENDS