aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2015-09-26 19:07:22 +0200
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-09-28 07:30:34 +0000
commitcd8eb6e92e4bcaa075ad7adeb674881da867542e (patch)
treebbda72f4ce01ecb4bc5704853e62c521b7fb1178 /debian
parenteaf474674902d765e4ee08db03637ad00947ec01 (diff)
debian: Enable parallel package build
Debian packages used to build with parallel build enabled when debian/rules used autotools but with switching to CMake the parallel build failed sometimes. Now the CMake based build system seems to be working for parallel builds, too, thus it seems to be safe to enable parallel building of .debs again. Change-Id: I79003bf6c4b74640f24d907b763a5cc3da595e68 Reviewed-on: https://code.wireshark.org/review/10657 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 3097f65060..c2cabc15cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: \(.*\)-.*/\1/p')
export docdir = /usr/share/doc/wireshark-doc
%:
- dh $@ --with python2 --buildsystem cmake --with quilt # --parallel
+ dh $@ --with python2 --buildsystem cmake --with quilt --parallel
override_dh_auto_configure:
dh_auto_configure -- -DENABLE_HTML_GUIDES=ON -DCMAKE_INSTALL_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \