aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2006-01-31 22:22:05 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2006-01-31 22:22:05 +0000
commitc8dd927e0c6dd23f065c965f08e4921ed2635fda (patch)
tree2c4b99a172f89f5f443d783e7e2cd448eec1019d /configure.in
parent42bf48fa74032b40af0c750daf9e0daca6c23d68 (diff)
It was hard.. but at the end I won (or at least i believe so...).
After install hello_world.lua works. svn path=/trunk/; revision=17137
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cabd6fc37d..3d52e711bc 100644
--- a/configure.in
+++ b/configure.in
@@ -749,6 +749,41 @@ else
fi
+dnl lua check
+AC_MSG_CHECKING(whether to use liblua for the lua scripting plugin)
+
+AC_ARG_WITH(lua,
+[ --with-lua[[=DIR]] use liblua (located in directory DIR, if supplied) for the lua scripting plugin. [[default=no]]],
+[
+ if test $withval = no
+ then
+ want_lua=no
+ elif test $withval = yes
+ then
+ want_lua=yes
+ else
+ want_lua=yes
+ lua_dir=$withval
+ fi
+],[
+ #
+ # Use liblua if it's present, otherwise don't.
+ #
+ want_lua=no
+ lua_dir=
+])
+if test "x$want_lua" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_LIBLUA_CHECK
+ if test "x$want_lua" = "xno" ; then
+ AC_MSG_RESULT(liblua not found - disabling support for the lua scripting plugin)
+ fi
+fi
+AM_CONDITIONAL(HAVE_LIBLUA, test x$want_lua = xyes)
+
+
dnl ipv6 check
AC_ARG_ENABLE(ipv6,
[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],enable_ipv6=$enableval,enable_ipv6=yes)
@@ -1256,6 +1291,7 @@ AC_OUTPUT(
plugins/gryphon/Makefile
plugins/h223/Makefile
plugins/irda/Makefile
+ plugins/lua/Makefile
plugins/lwres/Makefile
plugins/mate/Makefile
plugins/megaco/Makefile
@@ -1294,6 +1330,12 @@ else
pcre_message="yes"
fi
+if test "x$want_lua" = "xyes" -a "x$have_plugins" = "xyes" ; then
+ lua_message="yes"
+else
+ lua_message="no"
+fi
+
if test "x$want_ssl" = "xno" ; then
ssl_message="no"
else
@@ -1335,6 +1377,7 @@ echo " Build dftest : $enable_dftest"
echo ""
echo " Install setuid : $setuid_message"
echo " Use plugins : $have_plugins"
+echo " Build lua plugin : $lua_message"
echo " Use GTK+ v2 library : $enable_gtk2"
if test "x$enable_gtk2" = "xyes" ; then
echo " Use threads : $enable_threads"