aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-04-25 07:44:04 +0000
committerGuy Harris <guy@alum.mit.edu>2001-04-25 07:44:04 +0000
commitb349fbcbf0d26acdb048f9b5b45b6795299f8037 (patch)
treef1a8d3057e632d5b2a093a4be9f68664aa379b0a /configure.in
parentda38a630cbf7fbaa0f6760eb7f119cb34c1d68d2 (diff)
Fail if both UCD and CMU SNMP headers are found; we have no idea which
of the two libraries is installed - or, if both are installed in different directories, or if a shared library for one and an unshared library for another are installed in the same directory, which one we'll get if we link with "-lsnmp" - so we have no idea whether the header files with which we compile will match the library with which we link. svn path=/trunk/; revision=3382
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 858b56e800..163d7f5d26 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.120 2001/04/19 01:08:16 guy Exp $
+# $Id: configure.in,v 1.121 2001/04/25 07:44:04 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -367,6 +367,18 @@ else
AC_CHECK_HEADERS(ucd-snmp/snmp.h ucd-snmp/version.h snmp/snmp.h snmp/version.h)
#
+ # If we found both UCD and CMU SNMP headers, die, as both
+ # packages install the SNMP library as "libsnmp", so either
+ # only one of them is present or they're in different
+ # directories, and we run the risk of picking up the headers
+ # from one and the library from another.
+ #
+ if test "$ac_cv_header_ucd_snmp_snmp_h" = yes -a \
+ "$ac_cv_header_snmp_snmp_h" = yes ; then
+ AC_MSG_ERROR([Both UCD and CMU SNMP libraries found - uninstall one of them.])
+ fi
+
+ #
# This may require "-lkstat" on Solaris, sigh.
#
AC_CHECK_LIB(snmp, sprint_objid,