aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2011-05-17 19:59:18 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2011-05-17 19:59:18 +0000
commit99a76aca4609eb6cb4c087baa7354e124b702a3d (patch)
tree298223bc29b5eef8ba59da1363286a0155375e0b /configure.in
parenta385b7c9f34e82613020789208f24a52a56c8a30 (diff)
Fix https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5875 :
Error out if the user asked us to install dumpcap with a particular group but we are not building dumpcap. svn path=/trunk/; revision=37208
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 48e3601236..515d9f43cb 100644
--- a/configure.in
+++ b/configure.in
@@ -1460,6 +1460,9 @@ AC_ARG_WITH(dumpcap-group,
if test "x$withval" = "xyes"; then
AC_MSG_ERROR([No dumpcap group specified.])
elif test "x$withval" != "xno"; then
+ if test "x$enable_dumpcap" = "xno" ; then
+ AC_MSG_ERROR(dumpcap group install works only with dumpcap but dumpcap is disabled)
+ fi
AC_MSG_RESULT($withval)
DUMPCAP_GROUP="$withval"
fi