aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorUwe Girlich <Uwe.Girlich@philosys.de>2000-07-06 10:03:44 +0000
committerUwe Girlich <Uwe.Girlich@philosys.de>2000-07-06 10:03:44 +0000
commit96c86d737aa7fba9b21991f96394a3f464aceb31 (patch)
tree9e50c3bf927c96fa7fc30c6cc1a381ad7b5c32ac /configure.in
parent792dcfb55de8bae5dd925f7a8e57a891eb0e8154 (diff)
SINIX-M systems don't know about strcasecmp(). I added the source file
from the GNU C Library 2.0.7 like I did it with strncasecmp(). svn path=/trunk/; revision=2119
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 87b981b352..c17abb74c8 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.93 2000/07/04 12:09:44 gram Exp $
+# $Id: configure.in,v 1.94 2000/07/06 10:03:43 girlich Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -280,6 +280,15 @@ fi
AC_SUBST(STRERROR_C)
AC_SUBST(STRERROR_O)
+AC_CHECK_FUNC(strcasecmp, STRCASECMP_O="",
+ STRCASECMP_O="strcasecmp.o")
+if test "$ac_cv_func_strcasecmp" = no ; then
+ STRCASECMP_C="strcasecmp.c"
+ STRCASECMP_O="strcasecmp.o"
+fi
+AC_SUBST(STRCASECMP_C)
+AC_SUBST(STRCASECMP_O)
+
AC_CHECK_FUNC(strncasecmp, STRNCASECMP_O="",
STRNCASECMP_O="strncasecmp.o")
if test "$ac_cv_func_strncasecmp" = no ; then