aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2001-02-01 20:21:25 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2001-02-01 20:21:25 +0000
commit8f1fff2e6a5c114c6beafd2983afb55acd3d66ae (patch)
treee33c08662c708dcfe71591897fe6ffab53bce135 /configure.in
parent07a925ef8b0568a2c5b8098d5734364a40eeb2f6 (diff)
Create a more modular type system for the FT_* types. Put them
into epan/ftypes. Re-write display filter routines using Lemon parser instead of yacc. Besides using a different tool, the new grammar is much simpler, while the display filter engine itself is more powerful and more easily extended. Add dftest executable, to test display filter "bytecode" generation. Add option to "configure" to build dftest or randpkt, both of which are not built by default. Implement Ed Warnicke's ideas about dranges in the new display filter and ftype code. Remove type FT_TEXT_ONLY in favor of FT_NONE, and have protocols registered as FT_PROTOCOL. Thus, FT_NONE is used only for simple labels in the proto tree, while FT_PROTOCOL is used for protocols. This was necessary for being able to make byte slices (ranges) out of protocols, like "frame[0:3]" Win32 Makefile.nmake's will be added tonight. svn path=/trunk/; revision=2967
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 33 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 64a5f4ad4d..e07cbb3028 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.112 2001/01/18 09:54:09 guy Exp $
+# $Id: configure.in,v 1.113 2001/02/01 20:21:13 gram Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -237,6 +237,31 @@ AC_SUBST(editcap_bin)
AC_SUBST(editcap_man)
+# Enable/disable dftest
+
+AC_ARG_ENABLE(dftest,
+[ --enable-dftest build dftest. [default=no]],,enable_dftest=no)
+
+if test "x$enable_dftest" = "xyes" ; then
+ dftest_bin="dftest"
+else
+ dftest_bin=""
+fi
+AC_SUBST(dftest_bin)
+
+
+# Enable/disable randpkt
+
+AC_ARG_ENABLE(randpkt,
+[ --enable-randpkt build randpkt. [default=no]],,enable_randpkt=no)
+
+if test "x$enable_randpkt" = "xyes" ; then
+ randpkt_bin="randpkt"
+else
+ randpkt_bin=""
+fi
+AC_SUBST(randpkt_bin)
+
dnl Checks for "gethostbyname()" - and "-lnsl", if we need it to get
dnl "gethostbyname()".
@@ -478,7 +503,6 @@ AC_CONFIG_SUBDIRS(epan wiretap)
AC_OUTPUT(
Makefile
doc/Makefile
- epan/Makefile
gtk/Makefile
packaging/Makefile
packaging/rpm/Makefile
@@ -488,7 +512,10 @@ AC_OUTPUT(
packaging/svr4/pkginfo
plugins/Makefile
plugins/gryphon/Makefile
- plugins/mgcp/Makefile)
+ plugins/mgcp/Makefile
+ tools/Makefile
+ tools/lemon/Makefile
+ ,)
# Pretty messages
@@ -512,6 +539,9 @@ echo "The Ethereal package has been configured with the following options."
echo " Build ethereal : $enable_ethereal"
echo " Build tethereal : $enable_tethereal"
echo " Build editcap : $enable_editcap"
+echo " Build randpkt : $enable_randpkt"
+echo " Build dftest : $enable_dftest"
+echo ""
echo " Install setuid : $setuid_message"
echo " Use pcap library : $enable_pcap"
echo " Use zlib library : $enable_zlib"