aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-02-16 01:00:01 +0000
committerGerald Combs <gerald@wireshark.org>2008-02-16 01:00:01 +0000
commit7706f9e17e3bf2f7a686db4cefaae18dbdb40d61 (patch)
tree124e39f833e826184fd27511c4b4eb632da3a3b7 /configure.in
parent98bacb3556206a81f78c1568f7703f28ba137f91 (diff)
Fix compilation on non-Windows systems.
svn path=/trunk/; revision=24340
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b7e0e35a94..1e2e29c8a8 100644
--- a/configure.in
+++ b/configure.in
@@ -829,6 +829,24 @@ else
fi
AC_SUBST(randpkt_bin)
+# Enable/disable rawshark
+
+AC_ARG_ENABLE(rawshark,
+ AC_HELP_STRING( [--enable-rawshark],
+ [build rawshark. @<:@default=yes@:>@]),
+ rawshark=$enableval,enable_rawshark=yes)
+
+if test "x$enable_rawshark" = "xyes" ; then
+ rawshark_bin="rawshark\$(EXEEXT)"
+ rawshark_man="rawshark.1"
+else
+ rawshark_bin=""
+ rawshark_man=""
+fi
+AC_SUBST(rawshark_bin)
+AC_SUBST(rawshark_man)
+
+
dnl Checks for "gethostbyname()" - and "-lnsl", if we need it to get
dnl "gethostbyname()".
@@ -1743,6 +1761,7 @@ echo " Build text2pcap : $enable_text2pcap"
echo " Build idl2wrs : $enable_idl2wrs"
echo " Build randpkt : $enable_randpkt"
echo " Build dftest : $enable_dftest"
+echo " Build rawshark : $enable_rawshark"
echo ""
echo " Install dumpcap setuid : $setuid_message"
echo " Use plugins : $have_plugins"