aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
commit55a6251e7c52b3610cd8992b541be919a5dca5aa (patch)
tree11537545c74d4f5276cfffaf8cb7b2ad4e6fbba8 /configure.in
parent71c8b6077b28245ed7f65e129bf0bcab1066947e (diff)
From Olivier Biot
New "matches" operater in display filter language. Uses PCRE. If a "matches" operator is found in a dfilter while libpcre has not been used to build the binary, then an exception is thrown after using dfilter_fail() to set an apporporiate error message. svn path=/trunk/; revision=9182
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 44 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 31e7b15f5a..aa3633dd6b 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.233 2003/11/18 08:13:05 guy Exp $
+# $Id: configure.in,v 1.234 2003/12/06 16:35:18 gram Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -520,6 +520,42 @@ else
fi
+dnl pcre check
+AC_MSG_CHECKING(whether to use libpcre for regular expressions in dfilters)
+
+AC_ARG_WITH(pcre,
+changequote(<<, >>)dnl
+<< --with-pcre[=DIR] use libpcre (located in directory DIR, if supplied) to use in dfilter regular expressions. [default=yes, if present]>>,
+changequote([, ])dnl
+[
+ if test $withval = no
+ then
+ want_pcre=no
+ elif test $withval = yes
+ then
+ want_pcre=yes
+ else
+ want_pcre=yes
+ pcre_dir=$withval
+ fi
+],[
+ #
+ # Use libpcre if it's present, otherwise don't.
+ #
+ want_pcre=ifpresent
+ pcre_dir=
+])
+if test "x$want_pcre" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_LIBPCRE_CHECK
+ if test "x$want_pcre" = "xno" ; then
+ AC_MSG_RESULT(libpcre not found - disabling support for perl compatible regular expressions in dfilters)
+ fi
+fi
+
+
dnl ipv6 check
AC_ARG_ENABLE(ipv6,
[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],enable_ipv6=$enableval,enable_ipv6=yes)
@@ -860,6 +896,12 @@ else
zlib_message="yes"
fi
+if test "x$want_pcre" = "xno" ; then
+ pcre_message="no"
+else
+ pcre_message="yes"
+fi
+
if test "x$have_good_adns" = "xyes" ; then
adns_message="yes"
else
@@ -894,6 +936,7 @@ echo " Build profile binaries : $enable_profile_build"
fi
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"
+echo " Use pcre library : $pcre_message"
echo " Use GNU ADNS library : $adns_message"
echo " Use IPv6 name resolution : $enable_ipv6"
echo " Use UCD SNMP/NET-SNMP library : $snmp_libs_message"