aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Kukosa <tomas.kukosa@siemens.com>2007-12-04 11:19:29 +0000
committerTomas Kukosa <tomas.kukosa@siemens.com>2007-12-04 11:19:29 +0000
commit08bbd29c71b8068e419f95a7a8cb7332ef0a3a3d (patch)
treef0bdb59e0947e9cfeac882b6b58a4753af6511be /configure.in
parent48537a7a6505e68faadbed9837a4159c2758d442 (diff)
Support for RPCAP features in GUI (from Boris Misenov, see Bug 1366)
- retrieving the list of remote PCAP interfaces - password authentication support - UDP data fransfer - packet sampling (available in WinPcap 4.x) etc. fix problem if non-default rpcap port is used svn path=/trunk/; revision=23750
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b4d50f1594..72c67e6cda 100644
--- a/configure.in
+++ b/configure.in
@@ -884,6 +884,28 @@ fi
AC_SUBST(dumpcap_bin)
AC_SUBST(dumpcap_man)
+dnl pcap remote check
+AC_MSG_CHECKING(whether to use libpcap remote capturing feature)
+
+AC_ARG_WITH(pcap-remote,
+[ --with-pcap-remote use libpcap remote capturing (requires libpcap)],
+[
+ if test $withval = no
+ then
+ want_pcap_remote=no
+ else
+ want_pcap_remote=yes
+ fi
+],[
+ want_pcap_remote=no
+])
+if test "x$want_pcap_remote" = "xno" -o "x$want_pcap" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_PCAP_REMOTE_CHECK
+fi
+
dnl zlib check
AC_MSG_CHECKING(whether to use zlib for reading compressed capture files)