aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-01-04 17:43:19 -0800
committerGuy Harris <guy@alum.mit.edu>2015-01-05 01:44:12 +0000
commitfc39b9b151c94054d73e1aa8cdc4bb610045d661 (patch)
tree64cc81c8008712cba238666abd458319bb7fdf3a /configure.ac
parent533f85785b3149c13a68658294a5ec3f24f02143 (diff)
In CMake, check for thousands-grouping support in the GLib printf routines.
We do that with the autotools; do it with CMake as well. We could, in theory, handle thosands-grouping ourselves, on all platforms supporting ANSI C (for which read "all platforms we care about") by using localeconv()'s thousands_sep and grouping items, but that's a bit more work. Fix autotools' comment for that item while we're at it (it checks the GLib printf routines, not the system printf routines). Change-Id: I000f0f3b955d9b192ade15e3fabc46d6b48a052e Reviewed-on: https://code.wireshark.org/review/6317 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 89a15d4447..1194aa8e54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1880,7 +1880,7 @@ CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
if test "$ac_cv_glib_supports_printf_grouping" = yes ; then
AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_GLIB_PRINTF_GROUPING, 1, [Define if your printf() function supports thousands grouping.])
+ AC_DEFINE(HAVE_GLIB_PRINTF_GROUPING, 1, [Define if GLib's printf functions support thousands grouping.])
else
AC_MSG_RESULT(no)
fi