aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2017-03-06 21:22:39 +0100
committerMichael Mann <mmann78@netscape.net>2017-04-12 11:28:16 +0000
commitc6fb9ee21495a06ece8681e81872dd23d0d4be85 (patch)
tree817358f3e7add3de1b055b0b36d97a732fd79335 /configure.ac
parent5be11a5984c32e592e773c3049342861d4f30db1 (diff)
Add -Wduplicated-branches to extra warnings
Change-Id: I11d60b4405f4fde039affcdeebb13a3ceb2aded6 Reviewed-on: https://code.wireshark.org/review/20428 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 166c507bbd..5d8673530e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,6 +748,10 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# never enable this one with -Werror.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
+
+ # Works only with GCC 7
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wduplicated-branches)
+
fi
])