aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBart Van Assche <bvanassche@acm.org>2015-05-29 16:51:17 +0200
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-05-31 13:54:04 +0000
commitacde1e6f37c5ce2dd3b5cf3d4afc11bc3ebc6d53 (patch)
tree402146c903f5122bfaba2d66d4f6e811a3e0d6e7 /configure.ac
parent28481cda0119de767ff1baba96b793c3690eb4bf (diff)
configure.ac: openSUSE build fix
For some Linux distro's (e.g. openSUSE) the Qt4 tools have no suffix and the Qt5 tools have the suffix "-qt5". On such systems search for the Qt5 tools first. This avoids that compilation fails with the following error message: In file included from follow_stream_dialog.cpp:23:0: ui_follow_stream_dialog.h: In member function 'void Ui_FollowStreamDialog::retranslateUi(QDialog*)': ui_follow_stream_dialog.h:152:110: error: 'UnicodeUTF8' is not a member of 'QApplication' e(QApplication::translate("FollowStreamDialog", "Follow Stream", 0, QApplicatio ^ Bug: 11233 Change-Id: I09ccdb6a74043b6d952814b74fec5d618e6e26aa Reviewed-on: https://code.wireshark.org/review/8686 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac143
1 files changed, 58 insertions, 85 deletions
diff --git a/configure.ac b/configure.ac
index 4935c533e2..3e8b031af7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1815,98 +1815,71 @@ fi
#
# "make dist" requires that we have the Qt build tools.
#
-# Annoyingly, at least on Fedora 16, uic and moc are named XXX-qt4
-# rather than just XXX, perhaps to allow Qt 3 and Qt 4 tools to be
-# installed; if they're still doing that in current Fedora releases,
-# perhaps there will also be XXX-qt5 when they pick up Qt 5.
+# Annoyingly, on some Linux distros (e.g. Debian) the Qt 5 tools have no
+# suffix and the Qt 4 tools have suffix -qt4. On other distros (e.g. openSUSE)
+# the Qt 5 tools have suffix -qt5 and the Qt 4 tools have no suffix. Hence
+# check for Qt tools in the following suffix order: "-qt5", "", "-qt4".
#
-AC_PATH_PROG(UIC, uic)
-if test "x$UIC" = x
-then
- AC_PATH_PROG(UIC, uic-qt5)
- if test "x$UIC" = x
- then
- AC_PATH_PROG(UIC, uic-qt4)
- if test "x$UIC" = x
- then
- if test "x$have_qt" != "xno"; then
- #
- # If you want to build with Qt, you'd better
- # have uic.
- #
- AC_MSG_ERROR(I couldn't find uic or uic-qt5 or uic-qt4; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- UIC=uic
- fi
- fi
+AC_PATH_PROGS(UIC, [uic-qt5 uic uic-qt4])
+if test "x$UIC" = x; then
+ if test "x$have_qt" != "xno"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have uic.
+ #
+ AC_MSG_ERROR(I couldn't find uic or uic-qt5 or uic-qt4; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ UIC=uic
fi
fi
AC_SUBST(UIC)
-AC_PATH_PROG(MOC, moc)
-if test "x$MOC" = x
-then
- AC_PATH_PROG(MOC, moc-qt5)
- if test "x$MOC" = x
- then
- AC_PATH_PROG(MOC, moc-qt4)
- if test "x$MOC" = x
- then
- if test "x$have_qt" != "xno"; then
- #
- # If you want to build with Qt, you'd better
- # have moc.
- #
- AC_MSG_ERROR(I couldn't find moc or moc-qt5 or moc-qt4; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- MIC=moc
- fi
- fi
+AC_PATH_PROGS(MOC, [moc-qt5 moc moc-qt4])
+if test "x$MOC" = x; then
+ if test "x$have_qt" != "xno"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have moc.
+ #
+ AC_MSG_ERROR(I couldn't find moc or moc-qt5 or moc-qt4; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ MOC=moc
fi
fi
AC_SUBST(MOC)
-AC_PATH_PROG(RCC, rcc)
-if test "x$RCC" = x
-then
- AC_PATH_PROG(RCC, rcc-qt5)
- if test "x$RCC" = x
- then
- AC_PATH_PROG(RCC, rcc-qt4)
- if test "x$RCC" = x
- then
- if test "x$have_qt" != "xno"; then
- #
- # If you want to build with Qt, you'd better
- # have moc.
- #
- AC_MSG_ERROR(I couldn't find rcc or rcc-qt5; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- RCC=rcc
- fi
- fi
+AC_PATH_PROGS(RCC, [rcc-qt5 rcc rcc-qt4])
+if test "x$RCC" = x; then
+ if test "x$have_qt" != "xno"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have moc.
+ #
+ AC_MSG_ERROR(I couldn't find rcc or rcc-qt5; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ RCC=rcc
fi
fi
AC_SUBST(RCC)