aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-05 18:31:11 +0100
committerMichael Mann <mmann78@netscape.net>2015-12-22 12:24:16 +0000
commitac0eb6043be787428a194c163b55c852c8cb5be2 (patch)
tree74a195f4a020453d811127323e95da2ef80627d6 /configure.ac
parent0e4a7429db488b25941be4aa66405f9c2f4915e5 (diff)
extcap: add randpktdump, a random packet generator.
This new extcap is for testing and educational purpose. It relies on rankpkt-core functions to generate random packets. Change-Id: If6890f0673545682995a2079458108edc0913b30 Reviewed-on: https://code.wireshark.org/review/11764 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7cb6c30af..18dfb8665b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2330,6 +2330,47 @@ else
AC_MSG_RESULT(no)
fi
+dnl randpktdump check
+AC_MSG_CHECKING(whether to build randpktdump)
+
+AC_ARG_ENABLE(randpktdump,
+ AC_HELP_STRING( [--enable-randpktdump],
+ [build androiddump @<:@default=yes@:>@]),
+ randpktdump=$enableval,enable_randpktdump=yes)
+
+if test "x$enable_randpktdump" = "xyes" ; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
+if test "x$enable_sshdump" = "xyes" ; then
+ if test "x$have_good_libssh" = "xyes" ; then
+ sshdump_bin="sshdump\$(EXEEXT)"
+ sshdump_man="sshdump.1"
+ else
+ echo "Can't find libssh. Disabling sshdump."
+ enable_sshdump=no
+ sshdump_bin=""
+ sshdump_man=""
+ fi
+else
+ sshdump_bin=""
+ sshdump_man=""
+fi
+AC_SUBST(sshdump_bin)
+AC_SUBST(sshdump_man)
+
+if test "x$enable_randpktdump" = "xyes" ; then
+ randpktdump_bin="randpktdump\$(EXEEXT)"
+ randpktdump_man=""
+else
+ randpktdump_bin=""
+ randpktdump_man=""
+fi
+AC_SUBST(randpktdump_bin)
+AC_SUBST(randpktdump_man)
+
# Enable/disable echld
AC_ARG_ENABLE(echld,
AC_HELP_STRING( [--enable-echld],
@@ -3433,6 +3474,7 @@ echo " Build dftest : $enable_dftest"
echo " Build rawshark : $enable_rawshark"
echo " Build androiddump : $enable_androiddump"
echo " Build sshdump : $enable_sshdump"
+echo " Build randpktdump : $enable_randpktdump"
echo " Build echld : $have_echld"
echo ""
echo " Save files as pcap-ng by default : $enable_pcap_ng_default"