aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-10-19 12:27:11 +0200
committerAnders Broman <a.broman58@gmail.com>2016-10-20 05:03:07 +0000
commit9c3d81adde2d901a18fb0dc5a5dc2220f76cd920 (patch)
treecebcb733c078e2fce37acdecbd99713d71629dc0 /configure.ac
parentd38ed8e55f7df9b34b9a7859ff54dde726f2feb0 (diff)
Officially require Qt 4.8 or newer
Since v2.3.0rc0-1002-g1cd2255, Qt 4.8 became mandatory, reflect this in the version requirements. This will not affect a lot of distributions (RHEL and SLES only had Qt 4.6). For a more complete list of supported platforms, see https://wiki.wireshark.org/Development/Support_library_version_tracking While at it, correct some other minimum versions in documentation. Change-Id: I11f2dfba72c75429f6838404a81ed3b3dc302d5f Reviewed-on: https://code.wireshark.org/review/18314 Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Petri-Dish: Anders Broman <a.broman58@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 3 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 5a0cede700..9805e38f44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1237,7 +1237,7 @@ GTK2_MIN_VERSION=2.12.0
AC_SUBST(GTK2_MIN_VERSION)
GTK3_MIN_VERSION=3.0.0
AC_SUBST(GTK3_MIN_VERSION)
-QT_MIN_VERSION=4.7.0
+QT_MIN_VERSION=4.8.0
AC_SUBST(QT_MIN_VERSION)
# GTK+ and Qt checks; we require GTK+ $GTK2_MIN_VERSION or later or
# GTK3_MIN_VERSION or later or Qt $QT_MIN_VERSION or later.
@@ -1249,37 +1249,8 @@ AC_SUBST(QT_MIN_VERSION)
# We don't add $GTK_LIBS or $Qt_LIBS to LIBS, because we don't want to
# force all programs to be built with GTK+ or Qt.
#
-# Release dates for GTK+ versions:
-# https://en.wikipedia.org/wiki/GTK+#Releases
-# 2.12.0: 14 Sep 2007
-# 2.14.0: 04 Sep 2008
-# 2.16.0: 13 Mar 2009
-# 2.18.0: 23 Sep 2009
-# 2.20.0: 23 Mar 2010
-# 2.22.0: 23 Sep 2010
-# 2.24.0: 30 Jan 2011
-# 3.0.0: 10 Feb 2011
-# 3.2.0: 25 Sep 2011
-# 3.4.0: 26 Mar 2012
-# 3.6.0: 24 Sep 2012
-# 3.8.0: 25 Mar 2013
-# 3.10.0: 23 Sep 2013
-# 3.12.0: 25 Mar 2014
-# 3.14.0: 30 Sep 2014
-# 3.16.0: 22 Mar 2015
-# 3.18.0 22 Sep 2015
-#
-# Release dates for Qt versions:
-# https://en.wikipedia.org/wiki/List_of_Qt_releases
-# 4.6.0: 01 Dec 2009
-# 4.7.0: 21 Sep 2010
-# 4.8.0: 15 Dec 2011
-# 5.0.0: 19 Dec 2012
-# 5.1.0: 03 Jul 2013
-# 5.2.0: 12 Dec 2013
-# 5.3.0: 20 May 2014
-# 5.4.0: 10 Dec 2015
-# 5.5.0: 01 Jul 2015
+# For a list of library versions and their support across different platforms,
+# see https://wiki.wireshark.org/Development/Support_library_version_tracking
have_qt=no
have_gtk=no