aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Stieger <andreas.stieger@gmx.de>2014-12-03 00:09:42 +0000
committerBalint Reczey <balint@balintreczey.hu>2015-05-22 07:00:50 +0000
commit8f462b073755398205f3d67db0f4333c9c6984f9 (patch)
treebb266af61ff77ed32ddc57cbf14292ed9656c076 /configure.ac
parent2aea664d608740c35d684b3faebbeeb31ace0dcd (diff)
allow use of deprecated gdk-pixbuf functions
gdk-pixbuf 2.31.2 marked GdkPixdata including as deprecated, including gdk_pixbuf_new_from_inline. Wireshark builds with deprecated functions turned off by default, in this case GDK_PIXBUF_DISABLE_DEPRECATED. Patch to configure.ac to allow use of deprecated function until upstream has ported the code, or a replacement patch is available. Bug: 10750 gdk-pixbuf change: https://git.gnome.org/browse/gdk-pixbuf/commit/?id=48d76fb7f2d059013f5781b199245274998f05c9 Initial warning: ui_utils.c: In function 'window_icon_realize_cb': ui_utils.c:115:5: warning: implicit declaration of function 'gdk_pixbuf_new_from_inline' [-Wimplicit-function-declaration] icon = gdk_pixbuf_new_from_inline(-1, wsicon_16_pb_data, FALSE, NULL); ^ Causes these warnings due to the implicit declaration: gui_utils.c:115:10: warning: assignment makes pointer from integer without a cast [enabled by default] icon = gdk_pixbuf_new_from_inline(-1, wsicon_16_pb_data, FALSE, NULL); ^ Fails the package checks in these lines: E: wireshark 64bit-portability-issue gui_utils.c:115, 117, 119, 121, 512 E: wireshark 64bit-portability-issue main.c:1513, 1519, 1525, 1531 E: wireshark 64bit-portability-issue prefs_layout.c:346, 347, 348, 349, 350, 351 E: wireshark 64bit-portability-issue stock_icons.c:413, 425 Change-Id: I85092753058cd2e5cda527e4321a7d92ac38facd Reviewed-on: https://code.wireshark.org/review/8578 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Balint Reczey <balint@balintreczey.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4ef6fa329d..bcd6f9e540 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1783,7 +1783,6 @@ fi
if test "$have_gtk" = "yes" ; then
# If we have GTK then add flags for it.
- CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;