aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2015-10-14 19:40:24 +0200
committerAnders Broman <a.broman58@gmail.com>2015-10-20 03:28:55 +0000
commit82ec0bb0fc6bf551693d26c8a575bb3fbd9d0264 (patch)
tree340b8d34a0b24b43294c27c2d6df1cc7691d7c8d /configure.ac
parenta86acb2ac7493430d5a506f6bbe5969098fc19f6 (diff)
Require libgcrypt 1.4.2, add cmake version detection
libgcrypt 1.4.2 is required since since v1.11.0-rc1-2787-g23f9100 ("Really add support for AEAD ciphers (GCM)") due to the use of gcry_cipher_setctr. Bump the version in configure.ac too. Add version check for gcrypt to cmake. Tested with CentOS 6 (cmake 2.8.12.2, libgcrypt 1.4.5). Change-Id: I93c3ed902a764d9d14675779e866230d073c96d5 Reviewed-on: https://code.wireshark.org/review/11043 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f5bef94174..f086f53d35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -607,9 +607,9 @@ AC_ARG_WITH([gcrypt],
[ with_gcrypt="$withval"; want_gcrypt="yes" ], with_gcrypt="yes")
if test "x$with_gcrypt" = "xyes"; then
- AM_PATH_LIBGCRYPT(1.1.92,
+ AM_PATH_LIBGCRYPT(1.4.2,
[
- echo "libgcrypt found, enabling ipsec decryption"
+ echo "libgcrypt found, enabling decryption for ipsec, ssl, etc."
AC_DEFINE(HAVE_LIBGCRYPT, 1, [Define to use libgcrypt])
gcrypt_message="yes"
]
@@ -617,7 +617,7 @@ if test "x$with_gcrypt" = "xyes"; then
if test x$libgcrypt_config_prefix != x ; then
AC_MSG_ERROR([[libgcrypt not found; install libgcrypt-devel package for your system]])
else
- echo "libgcrypt not found, disabling ipsec decryption"
+ echo "libgcrypt not found, disabling decryption for ipsec, ssl, etc."
gcrypt_message="no"
fi