aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-02-23 14:33:54 +0100
committerRoland Knall <rknall@gmail.com>2016-03-04 05:53:56 +0000
commit68d4ba212c839631c639974b36fc283a9e90bc5e (patch)
tree592cd199aefc2e487a5d044c178fffdba448614e /configure.ac
parent5a66318272c3d6db4fc372976e761fa5e285909e (diff)
extcap: add local_interfaces_to_list() to wsutil.
This new function abstracts the creation of a list of the local interfaces that will be used by future extcaps to generate specific filters. Sshdump now uses it to create a pcap filter. Change-Id: I5b75a266f81104b3c9bcb3e51de246b7cc8785ce Reviewed-on: https://code.wireshark.org/review/14092 Reviewed-by: João Valverde <j@v6e.pt> Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c917542472..c85651913c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2647,6 +2647,7 @@ AC_CHECK_HEADERS(fcntl.h getopt.h grp.h inttypes.h netdb.h pwd.h unistd.h)
AC_CHECK_HEADERS(sys/ioctl.h sys/param.h sys/socket.h sys/sockio.h sys/stat.h sys/time.h sys/types.h sys/utsname.h sys/wait.h)
AC_CHECK_HEADERS(netinet/in.h)
AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h)
+AC_CHECK_HEADERS(ifaddrs.h)
#
# On Linux, check for some additional headers, which we need as a
@@ -2998,6 +2999,7 @@ AC_SUBST(POPCOUNT_LO)
AC_CHECK_FUNCS(getprotobynumber)
AC_CHECK_FUNCS(issetugid)
AC_CHECK_FUNCS(sysconf)
+AC_CHECK_FUNCS(getifaddrs)
dnl blank for now, but will be used in future
AC_SUBST(wireshark_SUBDIRS)